diff --git a/testing/bacula/APKBUILD b/testing/bacula/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..6adc4945666215c5ab86c328ca7cfd7bd04d9e78
--- /dev/null
+++ b/testing/bacula/APKBUILD
@@ -0,0 +1,86 @@
+# Contributor: Leonardo Arena <rnalrd@gmail.com>
+# Maintainer: Leonardo Arena <rnalrd@gmail.com>
+pkgname="bacula"
+pkgver=3.0.3
+pkgrel=0
+pkgdesc="Enterprise ready, network based backup program"
+url="http://www.bacula.org"
+license="GPL2"
+depends="postgresql openssl ncurses"
+makedepends="postgresql-dev openssl-dev ncurses-dev autoconf"
+install="$pkgname.pre-install $pkgname.post-install"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz
+bacula-dir-init
+bacula-dir-conf
+bacula-sd-init
+bacula-sd-conf
+bacula-fd-init
+bacula-fd-conf
+configure.in.patch
+os.m4.patch"
+
+prepare () {
+	cd "$srcdir/$pkgname-$pkgver"
+	patch -p1 < ../../configure.in.patch
+	patch -p1 < ../../os.m4.patch
+}
+
+build() {
+	cd "$srcdir/$pkgname-$pkgver"
+	export LDFLAGS=
+	# Need to run configure at least once
+	# in order to do not go into an infinite loop
+	./configure
+	make configure
+	make distclean
+
+	./configure --prefix=/usr \
+	 --sysconfdir=/etc/bacula \
+	 --localstatedir=/var \
+	 --mandir=/usr/share/man \
+	 --docdir=/usr/share/doc \
+	 --infodir=/usr/share/info \
+	 --with-pid-dir=/var/run \
+	 --with-subsys-dir=/var/lock/subsys \
+	 --enable-largefile \
+	 --disable-nls \
+	 --with-openssl=/usr/include/openssl \
+	 --with-postgresql=/usr \
+	 --with-scriptdir=/etc/bacula/scripts \
+	 --with-working-dir=/var/bacula \
+	 --with-dir-user=bacula \
+	 --with-dir-group=bacula \
+	 --with-sd-user=bacula \
+	 --with-sd-group=bacula \
+	 --with-fd-user=root \
+	 --with-fd-group=root \
+	 --with-dir-password=pie9Sah6aZo4aiS5te5e \
+	 --with-fd-password=ca4pheexie1aeC1hee3i \
+	 --with-sd-password=Saphaech3xohmuDaDaLi
+
+	make || return 1
+}
+
+package() {
+	cd "$srcdir/$pkgname-$pkgver"
+	make DESTDIR="$pkgdir" install
+
+	for DAEMON in dir sd fd
+	do
+		install -Dm755 $srcdir/bacula-${DAEMON}-init \
+		 $pkgdir/etc/init.d/bacula-${DAEMON}
+		install -Dm644 $srcdir/bacula-${DAEMON}-conf \
+		 $pkgdir/etc/conf.d/bacula-${DAEMON}
+	done
+}
+
+md5sums="feba58691b674b12056359d459ad6940  bacula-3.0.3.tar.gz
+2e11ca528feb60adc1bb09a6488eb654  bacula-dir-init
+20f28a16f34e3f20ed18ed81b010e765  bacula-dir-conf
+38603c86eae43e8a38962bb8590c41dd  bacula-sd-init
+afe2f9a4d79d7d96eb9372d003d10f86  bacula-sd-conf
+38b0fe78acdc5e65aec3a59578e98a20  bacula-fd-init
+4500ce2d62bf9df33c07f70dc40f7b85  bacula-fd-conf
+ebc9c2bbc9be95c920723a3f142d8e19  configure.in.patch
+cf7a2a4e972697f54364654c4e282b8b  os.m4.patch"
diff --git a/testing/bacula/bacula-dir-conf b/testing/bacula/bacula-dir-conf
new file mode 100644
index 0000000000000000000000000000000000000000..17a56161f08ca3eea8bc3712cb27c5597f449e5f
--- /dev/null
+++ b/testing/bacula/bacula-dir-conf
@@ -0,0 +1,7 @@
+# Config file for /etc/init.d/bacula-dir
+
+# Options for the director daemon.
+# The DIR can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u bacula -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/testing/bacula/bacula-dir-init b/testing/bacula/bacula-dir-init
new file mode 100644
index 0000000000000000000000000000000000000000..c14f5c876b61a8ae311d694bbf60fd9f767a5ea7
--- /dev/null
+++ b/testing/bacula/bacula-dir-init
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/app-backup/bacula/files/3.0.3/bacula-dir-init,v 1.1 2009/11/08 17:14:46 wschlich Exp $
+
+depend() {
+	need net postgresql
+	after firewall
+	use dns bacula-fd bacula-sd
+}
+
+start() {
+	ebegin "Starting bacula director"
+	start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+		-- ${DIR_OPTIONS}
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping bacula director"
+	start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+	eend $?
+}
diff --git a/testing/bacula/bacula-fd-conf b/testing/bacula/bacula-fd-conf
new file mode 100644
index 0000000000000000000000000000000000000000..033ef74b4b1dfe9fff6d59c4ff7bdfcdb6a00c3c
--- /dev/null
+++ b/testing/bacula/bacula-fd-conf
@@ -0,0 +1,4 @@
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file daemon.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/testing/bacula/bacula-fd-init b/testing/bacula/bacula-fd-init
new file mode 100644
index 0000000000000000000000000000000000000000..618b3508c74a52650c2398e0303c415b13df4ed0
--- /dev/null
+++ b/testing/bacula/bacula-fd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/app-backup/bacula/files/3.0.3/bacula-fd-init,v 1.1 2009/11/08 17:14:46 wschlich Exp $
+
+depend() {
+	need net
+	use dns
+}
+
+start() {
+	ebegin "Starting bacula file daemon"
+	start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+		-- ${FD_OPTIONS}
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping bacula file daemon"
+	start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+	eend $?
+}
diff --git a/testing/bacula/bacula-sd-conf b/testing/bacula/bacula-sd-conf
new file mode 100644
index 0000000000000000000000000000000000000000..88e13aa0eb361bba6a6c8d439ea619e07e9099fd
--- /dev/null
+++ b/testing/bacula/bacula-sd-conf
@@ -0,0 +1,7 @@
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u bacula -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/testing/bacula/bacula-sd-init b/testing/bacula/bacula-sd-init
new file mode 100644
index 0000000000000000000000000000000000000000..38c9ea487d84a5330f302774a709bf11e81e30d8
--- /dev/null
+++ b/testing/bacula/bacula-sd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/app-backup/bacula/files/3.0.3/bacula-sd-init,v 1.1 2009/11/08 17:14:46 wschlich Exp $
+
+depend() {
+	need net
+	use dns
+}
+
+start() {
+	ebegin "Starting bacula storage daemon"
+	start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+		-- ${SD_OPTIONS}
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping bacula storage daemon"
+	start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid 
+	eend $?
+}
diff --git a/testing/bacula/bacula.post-install b/testing/bacula/bacula.post-install
new file mode 100644
index 0000000000000000000000000000000000000000..51274b5c3f414ccf43623ac97c9acca25baaa7db
--- /dev/null
+++ b/testing/bacula/bacula.post-install
@@ -0,0 +1,2 @@
+#!/bin/sh
+chown bacula.bacula /var/bacula
diff --git a/testing/bacula/bacula.pre-install b/testing/bacula/bacula.pre-install
new file mode 100644
index 0000000000000000000000000000000000000000..bfac8567a5d1eaf7c3eeae2ef2296ecc990a1556
--- /dev/null
+++ b/testing/bacula/bacula.pre-install
@@ -0,0 +1,4 @@
+#!/bin/sh
+addgroup -S bacula 2>/dev/null
+adduser -h /var/bacula/ -s /bin/false -G bacula -S -H -D bacula 2>/dev/null
+exit 0
diff --git a/testing/bacula/configure.in.patch b/testing/bacula/configure.in.patch
new file mode 100644
index 0000000000000000000000000000000000000000..cfe2a0b7cf3648d89bcaa36bf6c053903a6872c6
--- /dev/null
+++ b/testing/bacula/configure.in.patch
@@ -0,0 +1,23 @@
+--- bacula-3.0.3-orig/autoconf/configure.in	Sun Oct 18 09:10:16 2009
++++ bacula-3.0.3/autoconf/configure.in	Wed Dec  2 14:13:44 2009
+@@ -2576,6 +2576,20 @@
+    fi
+    TAPEDRIVE="/dev/nrmt0"
+   ;;
++alpine)
++   dnl Make sure hostname is resolved
++   ping -c 1 $hostname 2>&1 1>/dev/null
++   if test ! $? = 0; then
++      hostname="localhost"
++   fi
++   if `test -f /etc/alpine-release && grep -q alpine /etc/alpine-release`; then
++      DISTNAME="alpine"
++   fi
++   DISTVER=`cat /etc/alpine-release`
++   TAPEDRIVE="/dev/nst0"
++   PSCMD="ps -e -o pid,comm"
++   largefile_support="yes"
++  ;;
+ bsdi)
+    DISTVER=`uname -a |awk '{print $3}'`
+    TAPEDRIVE="/dev/nrmt0"
diff --git a/testing/bacula/os.m4.patch b/testing/bacula/os.m4.patch
new file mode 100644
index 0000000000000000000000000000000000000000..95dc5666ad3f7cf2d11d6ba52585b23d55cd43ee
--- /dev/null
+++ b/testing/bacula/os.m4.patch
@@ -0,0 +1,12 @@
+--- bacula-3.0.3-orig/autoconf/bacula-macros/os.m4	Sun Oct 18 09:10:16 2009
++++ bacula-3.0.3/autoconf/bacula-macros/os.m4	Wed Dec  2 13:48:30 2009
+@@ -201,6 +201,9 @@
+ elif test -f /etc/gentoo-release
+ then
+         DISTNAME=gentoo
++elif test -f /etc/alpine-release
++then
++        DISTNAME=alpine
+ elif test -f /etc/debian_version
+ then
+         DISTNAME=debian