diff --git a/community/rust/APKBUILD b/community/rust/APKBUILD
index e9ea9f94c7db030054af2a1c2355bbb0aa33b847..79d8ae4845297189b9cc2e9ae09fb83ad95fca36 100644
--- a/community/rust/APKBUILD
+++ b/community/rust/APKBUILD
@@ -10,7 +10,7 @@ _bootver=1.46.0
 pkgrel=0
 pkgdesc="The Rust Programming Language"
 url="https://www.rust-lang.org"
-arch="x86_64 armv7 armhf aarch64 x86 ppc64le"
+arch="x86_64 armv7 armhf aarch64 x86 ppc64le s390x"
 license="Apache-2.0 AND MIT"
 
 # gcc is needed at runtime just for linking. Someday rustc might invoke
@@ -37,7 +37,6 @@ makedepends_host="
 	libgit2-dev
 	openssl-dev
 	llvm$_llvmver-dev
-	llvm$_llvmver-test-utils
 	zlib-dev
 "
 
@@ -147,8 +146,18 @@ build() {
 		--python="$_python" \
 		--set="rust.musl-root=/usr" \
 		--set="target.$_target.llvm-config=/usr/lib/llvm$_llvmver/bin/llvm-config" \
+		--set="target.$_target.musl-root=/usr" \
+		--set="target.$_target.crt-static=false" \
+		--set="target.$_target.cc=${CROSS_COMPILE}gcc" \
+		--set="target.$_target.cxx=${CROSS_COMPILE}c++" \
+		--set="target.$_target.ar=${CROSS_COMPILE}ar" \
+		--set="target.$_target.linker=${CROSS_COMPILE}gcc" \
 		--set="target.$_build.musl-root=/usr" \
-		--set="target.$_build.crt-static=false"
+		--set="target.$_build.crt-static=false" \
+		--set="target.$_build.cc=gcc" \
+		--set="target.$_build.cxx=c++" \
+		--set="target.$_build.ar=ar" \
+		--set="target.$_build.linker=gcc"
 
 	# Allow warnings instead of just aborting the build
 	sed 's/#deny-warnings = .*/deny-warnings = false/' -i config.toml