diff --git a/testing/mycroft-skill-weather/APKBUILD b/testing/mycroft-skill-weather/APKBUILD
index 6fe5dee9582e03195bdb4089a15644e0e0aae2c9..37d1eee55487c7d5250e8ebea3ee5b7260a4502d 100644
--- a/testing/mycroft-skill-weather/APKBUILD
+++ b/testing/mycroft-skill-weather/APKBUILD
@@ -1,14 +1,19 @@
 # Contributor: Bart Ribbers <bribbers@disroot.org>
 # Maintainer: Bart Ribbers <bribbers@disroot.org>
 pkgname=mycroft-skill-weather
-pkgver=20.08_git20200806
+pkgver=20.08_git20210111
 pkgrel=0
-_commit="93bdd8c2f91033ea3f4a09fc992083f1d9f19e28"
+_commit="6a508d540fbc7342935886cb5820a96884acc693"
 pkgdesc="Mycroft AI official Weather Skill, providing weather conditions and forecasts"
 url="https://mycroft.ai/skills"
 arch="noarch"
 license="Apache-2.0"
-depends="python3 py3-multi-key-dict py3-pyowm py3-requests"
+depends="
+	py3-multi-key-dict
+	py3-pyowm
+	py3-requests
+	python3
+	"
 source="https://github.com/mycroftai/skill-weather/archive/$_commit/skills-weather-$_commit.tar.gz"
 options="!check" # No tests
 builddir="$srcdir/skill-weather-$_commit"
@@ -18,4 +23,4 @@ package() {
 	cp -r ./* "$pkgdir"/usr/share/mycroft/skills/mycroft-weather.mycroftai/
 }
 
-sha512sums="11f36088017415da63f6a89f1330ff74c9ff98563083b3c2aa1ed5edbf6a6dba5202ae2d4df28fb3a09ee9eb1d1402e4877083c8c76d51bfb1c6defa7f3a84ac  skills-weather-93bdd8c2f91033ea3f4a09fc992083f1d9f19e28.tar.gz"
+sha512sums="5dc9933ddea323fe4b3888e0f8046c1cb218a5ea95e8a9106fb1f4199bf43ec3d041b11884fc4d6fd4618ae7bba6b4b6432940f303473ea1ddf30b40f096019d  skills-weather-6a508d540fbc7342935886cb5820a96884acc693.tar.gz"