From c148b08da63f0cc0aae7eaee11b39c1b473886e7 Mon Sep 17 00:00:00 2001
From: Leo <thinkabit.ukim@gmail.com>
Date: Thu, 12 Nov 2020 18:29:21 -0300
Subject: [PATCH] testing/plata-theme: enable noir theme

---
 testing/plata-theme/APKBUILD | 33 ++++++++++++++++++++++++++++++---
 1 file changed, 30 insertions(+), 3 deletions(-)

diff --git a/testing/plata-theme/APKBUILD b/testing/plata-theme/APKBUILD
index ea29f15d7291..4c6e7075821e 100644
--- a/testing/plata-theme/APKBUILD
+++ b/testing/plata-theme/APKBUILD
@@ -2,10 +2,10 @@
 # Maintainer: Leo <thinkabit.ukim@gmail.com>
 pkgname=plata-theme
 pkgver=0.9.9
-pkgrel=0
+pkgrel=1
 pkgdesc="Gtk theme based on Material Design Refresh"
 url="https://gitlab.com/tista500/plata-theme"
-arch="noarch"
+arch="noarch !s390x"
 license="CC-BY-SA-4.0 AND GPL-2.0-or-later"
 makedepends="
 	automake
@@ -24,6 +24,10 @@ makedepends="
 	gtk-murrine-engine
 	"
 subpackages="
+	plata-noir:noir:noarch
+	plata-noir-gnome-shell:noir_gnome:noarch
+	plata-noir-gtk2:noir_gtk2:noarch
+	plata-noir-gtk3:noir_gtk3:noarch
 	plata-noir-compact:noir_compact:noarch
 	plata-noir-compact-gnome-shell:noir_compact_gnome:noarch
 	plata-noir-compact-gtk2:noir_compact_gtk2:noarch
@@ -62,7 +66,30 @@ package() {
 	rm -rf "$pkgdir"/usr/share/themes/Plata-Compact
 	rm -rf "$pkgdir"/usr/share/themes/Plata-Lumine
 	rm -rf "$pkgdir"/usr/share/themes/Plata-Lumine-Compact
-	rm -rf "$pkgdir"/usr/share/themes/Plata-Noir
+}
+
+noir() {
+	pkgdesc="Dark Plata theme"
+	amove usr/share/themes/Plata-Noir/index.theme
+	amove usr/share/themes/Plata-Noir/gtksourceview
+}
+
+noir_gtk3() {
+	pkgdesc="GTK+3.0 assets of Dark Plata theme"
+	install_if="plata-noir=$pkgver-r$pkgrel gtk+3.0"
+	amove usr/share/themes/Plata-Noir/gtk-3*
+}
+
+noir_gtk2() {
+	pkgdesc="GTK+2.0 assets of Dark Plata theme"
+	install_if="plata-noir=$pkgver-r$pkgrel gtk+2.0"
+	amove usr/share/themes/Plata-Noir/gtk-2*
+}
+
+noir_gnome() {
+	pkgdesc="GNOME Shell assets of Dark Plata theme"
+	install_if="plata-noir=$pkgver-r$pkgrel gnome-shell"
+	amove usr/share/themes/Plata-Noir/gnome-shell
 }
 
 noir_compact() {
-- 
GitLab