From b7fd48fc24bf87e56e3a0ac800437cb7a95fadd2 Mon Sep 17 00:00:00 2001
From: Ariadne Conill <ariadne@dereferenced.org>
Date: Sat, 31 Oct 2020 14:55:43 +0000
Subject: [PATCH] main/util-linux: dont depend on libeconf when bootstrapping

---
 main/util-linux/APKBUILD | 10 ++++------
 1 file changed, 4 insertions(+), 6 deletions(-)

diff --git a/main/util-linux/APKBUILD b/main/util-linux/APKBUILD
index e93b55a313da..5a5992688525 100644
--- a/main/util-linux/APKBUILD
+++ b/main/util-linux/APKBUILD
@@ -17,7 +17,7 @@ license="GPL-3.0-or-later AND GPL-2.0-or-later AND GPL-2.0-only AND
 	LGPL-2.1-or-later AND BSD-3-Clause AND BSD-4-Clause-UC AND Public-Domain"
 depends="blkid setpriv findmnt mcookie hexdump lsblk sfdisk cfdisk"
 makedepends_build="autoconf automake libtool"
-makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev libeconf-dev"
+makedepends_host="zlib-dev ncurses-dev linux-headers libcap-ng-dev"
 options="suid"
 source="https://www.kernel.org/pub/linux/utils/util-linux/v$_v/util-linux-$pkgver.tar.xz
 	ttydefaults.h
@@ -39,11 +39,11 @@ subpackages="$pkgname-doc $pkgname-dev $pkgname-bash-completion:bashcomp:noarch
 	sfdisk:_mv_bin
 	"
 if [ -z "$BOOTSTRAP" ]; then
-	makedepends_host="$makedepends_host linux-pam-dev python3-dev"
+	makedepends_host="$makedepends_host linux-pam-dev python3-dev libeconf-dev"
 	subpackages="$subpackages py3-libmount:_py3 runuser:_mv_bin"
-	_bootstrap_config="--enable-runuser"
+	_bootstrap_config="--enable-runuser --with-python=3 --with-econf"
 else
-	_bootstrap_config="--without-python"
+	_bootstrap_config="--without-python --without-econf"
 fi
 makedepends="$makedepends_build $makedepends_host"
 
@@ -72,8 +72,6 @@ build() {
 		--disable-last \
 		--disable-sulogin \
 		--disable-su \
-		--with-python=3 \
-		--with-econf \
 		--with-vendordir=/usr/lib \
 		$_bootstrap_config
 	make
-- 
GitLab