diff --git a/community/texlive/APKBUILD b/community/texlive/APKBUILD
index c3bebada22346d4f8c5c52d84d66ed2b03fa35cb..00c910149f809d925352a720b7dfda617628b467 100644
--- a/community/texlive/APKBUILD
+++ b/community/texlive/APKBUILD
@@ -2,7 +2,7 @@
 # Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
 pkgname=texlive
 pkgver=20200406
-pkgrel=4
+pkgrel=5
 pkgdesc="Comprehensive TeX document production system"
 url="https://tug.org/texlive/"
 arch="all !mips64 !s390x" # luatex fails on s390x
@@ -11,7 +11,8 @@ options="!check" # no unit tests provided
 depends="perl texmf-dist>=2020.55416"
 makedepends="freetype-dev libpng-dev poppler-dev icu-dev harfbuzz-dev
 	cairo-dev pixman-dev zziplib-dev libpaper-dev graphite2-dev
-	libxmu-dev fontconfig-dev libxaw-dev motif-dev"
+	libxmu-dev fontconfig-dev libxaw-dev motif-dev
+	gmp-dev mpfr-dev gd-dev"
 triggers="$pkgname.trigger=/usr/share/texmf-dist"
 subpackages="
 	$pkgname-static
@@ -49,8 +50,6 @@ build() {
 	# builders keep failing when -jN == nproc
 	export MAKEFLAGS="$MAKEFLAGS -j$((JOBS<16 ? JOBS : 16))"
 
-	# fixme: detect systemzziplib
-	#--with-system-zziplib \ fixme detect systemzziplib
 	../configure -C \
 		--build=$CBUILD \
 		--host=$CHOST \
@@ -95,15 +94,19 @@ build() {
 		--with-banner-add="/Alpine Linux" \
 		--with-system-cairo \
 		--with-system-freetype2 \
+		--with-system-gd \
+		--with-system-gmp \
 		--with-system-graphite2 \
 		--with-system-harfbuzz \
 		--with-system-icu \
 		--with-system-libpaper \
 		--with-system-libpng \
+		--with-system-mpfr \
 		--with-system-pixman \
 		--with-system-poppler \
 		--with-system-xpdf \
 		--with-system-zlib \
+		--with-system-zziplib \
 		--with-x-dvi-toolkit=motif \
 		--without-texinfo
 	make