diff --git a/testing/php7-pecl-uuid/APKBUILD b/testing/php7-pecl-uuid/APKBUILD
index 2c22447b5894ae7ab754285bc2bf2726046db987..09d8a1ecf5adf68fa909afb40f534a8921525421 100644
--- a/testing/php7-pecl-uuid/APKBUILD
+++ b/testing/php7-pecl-uuid/APKBUILD
@@ -3,34 +3,29 @@
 pkgname=php7-pecl-uuid
 _pkgreal=uuid
 pkgver=1.1.0
-_pkgver=${pkgver}
-pkgrel=0
+pkgrel=1
 pkgdesc="A wrapper around libuuid from the ext2utils project."
-url="https://pecl.php.net/package/$_pkgreal"
+url="https://pecl.php.net/package/uuid"
 arch="all"
-license="PHP"
-depends=""
-pecldepends="php7-dev autoconf util-linux-dev"
-makedepends="$pecldepends"
-source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
-builddir="$srcdir/$_pkgreal-$_pkgver"
+license="LGPL-2.1-or-later"
+depends="php7-common"
+makedepends="php7-dev autoconf re2c util-linux-dev"
+source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
+builddir="$srcdir/$_pkgreal-$pkgver"
 provides="php7-uuid=$pkgver-r$pkgrel" # for backward compatibility
 replaces="php7-uuid" # for backward compatibility
 
 build() {
-	cd "$builddir"
 	phpize7
 	./configure --prefix=/usr --with-php-config=php-config7
 	make
 }
 
 check() {
-	cd "$builddir"
 	make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
 }
 
 package() {
-	cd "$builddir"
 	make INSTALL_ROOT="$pkgdir"/ install
 	install -d "$pkgdir"/etc/php7/conf.d
 	echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/50_$_pkgreal.ini