diff --git a/testing/php7-mustache/APKBUILD b/testing/php7-mustache/APKBUILD
index bbcd46f0fc8a44290f72c2079faeb315af420b61..eb5530a51bc5ddfff32e590f7307e4b52d8db932 100644
--- a/testing/php7-mustache/APKBUILD
+++ b/testing/php7-mustache/APKBUILD
@@ -1,31 +1,18 @@
 # Maintainer: Renoir Boulanger <hello@renoirboulanger.com>
 pkgname="php7-mustache"
 _phpext="mustache"
-pkgver=0.9.0
-pkgrel=1
+pkgver=0.9.1
+pkgrel=0
 pkgdesc="PHP 7 PECL extension: C++ implementation of Mustache"
-giturl="https://github.com/jbboehr/php-mustache.git"
-url="https://github.com/jbboehr/php-mustache"
+url="https://pecl.php.net/package/mustache"
 arch="all"
 license="MIT"
-depends="libmustache"
-makedepends="php7-dev autoconf"
-# Look at commit ref for spec/ folder at https://github.com/jbboehr/mustache-spec
-_mustachespec_gitrev=72233f3ffda9e33915fd3022d0a9ebbcce265acd
-_pkg_filename=php-mustache-$pkgver
-source="php-mustache-$pkgver.tar.gz::https://github.com/jbboehr/php-mustache/archive/v$pkgver.tar.gz
-	mustache-spec-$_mustachespec_gitrev.tar.gz::https://github.com/jbboehr/mustache-spec/archive/$_mustachespec_gitrev.tar.gz"
-builddir="$srcdir/$_pkg_filename/"
-
-prepare() {
-	rm -rf "$builddir"/spec
-	ln -s "$srcdir"/mustache-spec-$_mustachespec_gitrev "$builddir"/spec
-	cd "$builddir"
-	default_prepare
-}
+depends="php7-common"
+makedepends="php7-dev autoconf re2c libmustache"
+source="https://pecl.php.net/get/$_phpext-$pkgver.tgz"
+builddir="$srcdir"/$_phpext-$pkgver
 
 build() {
-	cd "$builddir"
 	phpize7
 	./configure \
 		--build=$CBUILD \
@@ -37,16 +24,13 @@ build() {
 }
 
 check() {
-	cd "$builddir"
 	make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
 }
 
 package() {
-	cd "$builddir"
 	make INSTALL_ROOT="$pkgdir" install
 	install -d "$pkgdir"/etc/php7/conf.d
 	echo "extension=$_phpext.so" > "$pkgdir"/etc/php7/conf.d/70_$_phpext.ini
 }
 
-sha512sums="b0b84a0efd7438ca063144e899b10cf90ea91921109ad28bc4609f166c97eebc553fe1ee6fd809ea885233a90ebf649e607cc064a0e9b764ed8286a5ff5962cd  php-mustache-0.9.0.tar.gz
-d63ca7c3016190e101b2db153a33e4e523e0199e3fb3778733d791e4853bab20925046d0cb34bbde0985a4b6b78b1ec6003db1e2384693352d03f7d67799ed10  mustache-spec-72233f3ffda9e33915fd3022d0a9ebbcce265acd.tar.gz"
+sha512sums="0ff16f300cec312370effd68574e289a0993f3d45b1bb26469f19f3312ff8bfa9d2b3c682a3f2e5c4e20f41cb2c668269b17f3bd70272285dd007ab6bdf5327e  mustache-0.9.1.tgz"