Commit 14230b42 authored by Bart Ribbers's avatar Bart Ribbers
Browse files

testing/okular: fix -mobile subpackage

parent e76dec00
......@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=okular
pkgver=19.08.2
pkgrel=0
pkgrel=1
arch="all"
url="https://kde.org/applications/office/org.kde.okular"
pkgdesc="A universal document viewer"
......@@ -17,8 +17,15 @@ checkdepends="xvfb-run"
source="https://download.kde.org/stable/applications/$pkgver/src/okular-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang $pkgname-mobile"
prepare() {
default_prepare
mkdir "$builddir"/build
}
build() {
cmake \
cd "$builddir"/build
cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
......@@ -29,20 +36,25 @@ build() {
}
check() {
cd "$builddir"/build
# All other tests are broken, require OpenGL, etc
CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -R "^shelltest"
}
package() {
cd "$builddir"/build
DESTDIR="$pkgdir" make install
}
mobile() {
depends="kirigami2"
mkdir -p "$subpkgdir"/usr/bin
mkdir -p "$subpkgdir"/usr/lib/qt5
mkdir -p "$subpkgdir"/usr/share/applications
mv "$pkgdir"/usr/bin/okularkirigami "$subpkgdir"/usr/bin/
mv "$pkgdir"/usr/lib/qt5/qml "$subpkgdir"/usr/lib/qt5/
mv "$pkgdir"/usr/share/applications/org.kde.okular.kirigami.desktop "$subpkgdir"/usr/share/applications/
mv "$pkgdir"/usr/share/applications/org.kde.mobile.okular_plucker.desktop "$subpkgdir"/usr/share/applications/
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment