Commit e891db10 authored by Leo's avatar Leo
Browse files

main/perl-params-util: upgrade to 1.100

parent d21f840e
# Automatically generated by apkbuild-cpan, template 3
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=perl-params-util
pkgver=1.07
pkgrel=9
pkgdesc="Params::Util perl module"
#_pkgreal is used by apkbuild-cpan to find modules at MetaCpan
_pkgreal=Params-Util
pkgver=1.100
pkgrel=0
pkgdesc="Simple, compact and correct param-checking functions"
url="https://metacpan.org/release/Params-Util/"
arch="all"
license="GPL-2.0 or Artistic"
license="GPL-1.0-or-later OR Artistic-1.0-Perl"
depends="perl"
makedepends="perl-dev"
install=""
makedepends="perl-dev perl-config-autoconf"
checkdepends="perl-test-leaktrace"
subpackages="$pkgname-doc"
source="https://cpan.metacpan.org/authors/id/A/AD/ADAMK/Params-Util-$pkgver.tar.gz"
source="https://cpan.metacpan.org/authors/id/R/RE/REHSACK/Params-Util-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
_builddir="$srcdir"/Params-Util-$pkgver
prepare() {
local i
cd "$_builddir"
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
build() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
make
}
build() {
cd "$_builddir"
unset CFLAGS
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
make || return 1
make test || return 1
check() {
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
sha512sums="ff471b01b33414fc5e1c68d97c21171a95d3418c33e3c45f9910cc768898690e35051506a83ad9403a200336654c14b8efc9d471c4b3fe3321047a7603d6fd56 Params-Util-1.07.tar.gz"
sha512sums="3e15967becb9c1a90beec9c6eb914a274fc20a376a74d2709d43d25917eb482cf350ad1386c9ea5657865fb162c44f1126ef704eaa34eb911e18a6aaceebcc34 Params-Util-1.100.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment