Commit c30e7f73 authored by Bart Ribbers's avatar Bart Ribbers
Browse files

testing/anki: disable on riscv64

parent 1fc8dbb7
......@@ -5,14 +5,17 @@ pkgver=2.1.15
pkgrel=0
pkgdesc="flashcard program using spaced repetition"
url="https://apps.ankiweb.net/"
arch="noarch !armhf !mips !mips64 !ppc64le !s390x" # py3-qtwebengine unavailable for !archs
# armhf blocked by qt5-qtdeclarative -> py3-qtwebengine
# mips64, ppc64le and s390x are blocked by py3-qtwebengine
# riscv64 blocked by qt5-qtwebengine -> py3-qtwebengine
arch="noarch !armhf !mips64 !ppc64le !s390x !riscv64"
license="AGPL-3.0-or-later"
options="!check" # no test suite provided
makedepends="bash xdg-utils perl"
depends="py3-decorator py3-qt5 py3-qtwebengine py3-beautifulsoup4 py3-requests
py3-send2trash py3-pyaudio py3-markdown py3-jsonschema py3-distro"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/ankitects/anki/archive/2.1.15.tar.gz"
source="https://github.com/ankitects/anki/archive/$pkgver/anki-$pkgver.tar.gz"
build() {
......@@ -22,4 +25,6 @@ build() {
package() {
make DESTDIR="$pkgdir" install
}
sha512sums="5bad99d9bfa10782f1d5b69437f45ea8b44d7a65ac1defe1169379f6ce29727c05af896934169c5222b37a4c1b6f3e05b6d10a3a152cc32cfec432fdf2e19b79 anki-2.1.15.tar.gz"
sha512sums="
5bad99d9bfa10782f1d5b69437f45ea8b44d7a65ac1defe1169379f6ce29727c05af896934169c5222b37a4c1b6f3e05b6d10a3a152cc32cfec432fdf2e19b79 anki-2.1.15.tar.gz
"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment