Commit c15035b8 authored by Leo's avatar Leo
Browse files

main/mesa: upgrade to 19.3.1

parent c74d01ea
Pipeline #3994 failed with stages
in 9 minutes and 52 seconds
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=mesa
pkgver=19.2.7
pkgver=19.3.1
pkgrel=0
pkgdesc="Mesa DRI OpenGL library"
url="https://www.mesa3d.org"
......@@ -332,7 +332,7 @@ _vulkan_layer() {
mv "$pkgdir"/usr/lib/libVkLayer_MESA_overlay.so "$subpkgdir"/usr/lib
}
sha512sums="87a82664381432e956ee23dc92bec5accf667606232e38d9458d67132c16fdc44584f65671293b83f00c58ad7742b80e942a5d1bd66d457705be60aaaf35395b mesa-19.2.7.tar.xz
sha512sums="338d2e37122ef22cc4e27a2f3c39e23e419703a507ace99383c749a563936c5f0428cce9a68ac80d0bd2ff57be8a55f42aee0ed6d16bf6b77b4e59d428729568 mesa-19.3.1.tar.xz
cdf22d2da3328e116c379264886bd01fd3ad5cc45fe03dc6fd97bdc4794502598ee195c0b9d975fa264d6ac31c6fa108c0535c91800ecf4fcabfd308e53074cc adjust-cache-deflate-buffer.patch
cf849044d6cc7d2af4ff015208fb09d70bf9660538699797da21bda2ecb7c1892d312af83d05116afd826708d9caafb1d05a13f09139c558aea6fee931e3eee7 musl-fix-includes.patch
6793388662ed98ae2a6bd964573d9ae380195f078386f0402957a1c9ac61b691b48a82ed41045c7172533f25b44f249af10f17f7ac68c8e03847594962cd4b04 add-use-elf-tls.patch"
9aa207a38d538abbd8e7a7210e3081508563e85e8c27b2269b8f40fd62d9fc6fee0cb2f573a0e62c42f8ba0fb85740459b761f009d5991cfd9813d7614541908 add-use-elf-tls.patch"
diff --git meson.build meson.build
index 4afd8ca..ab9b365 100644
diff --git a/meson.build b/meson.build
index 898d025..0da4fc5 100644
--- a/meson.build
+++ b/meson.build
@@ -378,7 +378,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
@@ -387,7 +387,8 @@ if with_egl and not (with_platform_drm or with_platform_surfaceless or with_plat
endif
# Android uses emutls for versions <= P/28. For USE_ELF_TLS we need ELF TLS.
-if not with_platform_android or get_option('platform-sdk-version') >= 29
-if host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
+with_use_elf_tls = get_option('use-elf-tls')
+if with_use_elf_tls and not with_platform_android or get_option('platform-sdk-version') >= 29
+if with_use_elf_tls and host_machine.system() != 'windows' and (not with_platform_android or get_option('platform-sdk-version') >= 29)
pre_args += '-DUSE_ELF_TLS'
endif
diff --git meson_options.txt meson_options.txt
index b768c15..2533220 100644
diff --git a/meson_options.txt b/meson_options.txt
index 626baf3..6e4637c 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -358,3 +358,9 @@ option(
@@ -366,3 +366,9 @@ option(
value : 25,
description : 'Android Platform SDK version. Default: Nougat version.'
)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment