Commit 6eacc73d authored by Leo's avatar Leo

main/heimdal: disable berkeleydb support

parent 66c0e72d
Pipeline #48303 skipped
......@@ -3,15 +3,15 @@
pkgname=heimdal
pkgver=7.7.0
_ver=${pkgver/_rc/rc}
pkgrel=1
pkgdesc="An implementation of Kerberos 5"
pkgrel=2
pkgdesc="Iplementation of Kerberos 5"
arch="all"
url="https://github.com/heimdal/"
license="BSD-3-Clause"
depends="krb5-conf"
depends_dev="openssl-dev e2fsprogs-dev db-dev"
depends_dev="openssl-dev e2fsprogs-dev"
makedepends="$depends_dev autoconf automake bash gawk libtool
ncurses-dev perl readline-dev sqlite-dev texinfo perl-json"
ncurses-dev perl readline-dev sqlite-dev texinfo perl-json gdbm-dev"
options="suid !check" #FIXME: FAIL: snprintf-test
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs $pkgname-openrc"
source="https://github.com/heimdal/heimdal/releases/download/heimdal-$pkgver/heimdal-$pkgver.tar.gz
......@@ -23,7 +23,6 @@ source="https://github.com/heimdal/heimdal/releases/download/heimdal-$pkgver/hei
heimdal_missing-include.patch
CVE-2018-16860.patch
"
builddir="$srcdir/$pkgname-$_ver"
# secfixes:
# 7.5.3-r4:
......@@ -42,8 +41,7 @@ prepare() {
}
build() {
export LDFLAGS="${LDFLAGS} -Wl,--as-needed"
export LIBS="-ldb"
export LDFLAGS="$LDFLAGS -Wl,--as-needed"
./configure \
--build=$CBUILD \
......@@ -51,11 +49,12 @@ build() {
--prefix=/usr \
--enable-shared=yes \
--without-x \
--with-berkeley-db \
--without-berkeley-db \
--with-readline-lib=/usr/lib \
--with-readline-include=/usr/include/readline \
--with-sqlite3=/usr \
--without-openssl
--without-openssl \
--with-db-type-preference=
# make sure we use system version
rm -r lib/sqlite lib/com_err
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment