diff --git a/testing/wicd/APKBUILD b/testing/wicd/APKBUILD
new file mode 100644
index 0000000000000000000000000000000000000000..e3bb51392c65004abb0d21654e47487197204fa4
--- /dev/null
+++ b/testing/wicd/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Konstantin Khokhlov <khohlovsky@gmail.com>
+pkgname=wicd
+pkgver=1.7.2.4
+pkgrel=0
+pkgdesc="Wicd is an open source wired and wireless network manager for Linux"
+url="http://wicd.sourceforge.net/"
+arch="noarch"
+license="GPLv2"
+depends="python2 py-gtk dbus py-dbus wireless-tools iproute2 pm-utils py2-babel"
+makedepends="py-setuptools"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/dpaleino/wicd/archive/1.7.2.4.tar.gz
+wicd.initd"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+  cd "$builddir"
+  python setup.py configure \
+    --distro=gentoo \
+    --no-install-init \
+    --no-install-man
+
+}
+
+package() {
+  cd "$builddir"
+  python setup.py install --root="$pkgdir" --prefix="/usr"
+  install -m755 -D "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
+}
+
+sha512sums="3b42e94de3c6f0bfcbb45e7f6b598e7b6dbec25ff29ce3e1744876f75e0662d4f3ad0ccaba1a24e728fd63fc492d6f7d5c768247b9d55bcc2994df0d1b52bf80  wicd-1.7.2.4.tar.gz
+6e4d550bc496cb28b6234f6feb1c16ee595fd9ae77bfcb0bb35b41a66e68d638d062cb3ac4abe3548fcf22b51189fbf26cd7c269995224650de495ff67ac24ba  wicd.initd"
diff --git a/testing/wicd/wicd.initd b/testing/wicd/wicd.initd
new file mode 100755
index 0000000000000000000000000000000000000000..071f3fd52a754d2b060fbdbd5cb6db796ac19ee7
--- /dev/null
+++ b/testing/wicd/wicd.initd
@@ -0,0 +1,36 @@
+#!/sbin/openrc-run
+## Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+WICD_DAEMON=/usr/sbin/wicd
+WICD_PIDFILE=/var/run/wicd/wicd.pid
+
+depend() {
+	need dbus
+	after hald
+	provide net
+}
+
+start() {
+	ebegin "Starting wicd daemon"
+	[ -f /etc/wicd/wired-settings.conf ] && sed -i 's/^\[\]$//' /etc/wicd/wired-settings.conf
+	"${WICD_DAEMON}" >/dev/null 2>&1
+	eend $?
+}
+
+stop() {
+	ebegin "Stopping wicd daemon and closing connections"
+	"${WICD_DAEMON}" -k >/dev/null 2>&1
+	eend $?
+}
+
+force_kill() {
+	ebegin "Stopping wicd daemon"
+	start-stop-daemon --stop --pidfile "${WICD_PIDFILE}"
+	eend $?
+}
+
+restart() {
+	force_kill
+	start
+}