Commit 7698471d authored by J0WI's avatar J0WI
Browse files

community/lua-*: add lua 5.4

parent 52cc718b
Pipeline #81289 failed with stages
in 424 minutes
......@@ -4,7 +4,7 @@ pkgname=lua-copas
_pkgname=copas
pkgver=2.0.2
_pkgver=${pkgver//./_}
pkgrel=3
pkgrel=4
pkgdesc="Coroutine Oriented Portable Asynchronous Services for Lua"
url="http://keplerproject.github.io/copas/"
arch="noarch"
......@@ -19,7 +19,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/arch
skip-broken-test.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-$_pkgname:_subpackage"
checkdepends="$checkdepends lua$_v"
......
......@@ -4,7 +4,7 @@ pkgname=lua-coxpcall
_pkgname=coxpcall
pkgver=1.17.0
_pkgver=${pkgver//./_}
pkgrel=0
pkgrel=1
pkgdesc="Coroutine safe xpcall and pcall for Lua"
url="http://keplerproject.github.io/coxpcall/"
arch="noarch"
......@@ -15,7 +15,7 @@ subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/archive/v$_pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$_pkgver"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-$_pkgname:_package"
......
......@@ -3,7 +3,7 @@
pkgname=lua-luassert
_pkgname=luassert
pkgver=1.8.0
pkgrel=0
pkgrel=1
pkgdesc="Assertion library for Lua"
url="https://github.com/Olivine-Labs/luassert"
arch="noarch"
......@@ -15,7 +15,7 @@ builddir="$srcdir/$_pkgname-$pkgver"
# lua-luassert and we wanna avoid circular dependencies.
options="!check"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
done
......
......@@ -4,7 +4,7 @@ pkgname=lua-mediator
_pkgname=mediator_lua
pkgver=1.1.2
_pkgver=$pkgver-0
pkgrel=1
pkgrel=2
pkgdesc="Mediator pattern implementation for pub-sub management"
url="http://olivinelabs.com/mediator_lua/"
arch="noarch"
......@@ -16,7 +16,7 @@ builddir="$srcdir/$_pkgname-$_pkgver"
# lua-mediator and we wanna avoid circular dependencies.
options="!check"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
done
......
......@@ -3,7 +3,7 @@
pkgname=lua-optparse
_pkgname=optparse
pkgver=1.4
pkgrel=0
pkgrel=1
pkgdesc="Parse and process command-line options"
url="https://github.com/gvvaughan/optparse"
arch="noarch"
......@@ -13,7 +13,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/gvvaughan/$_pkgname/archive/
builddir="$srcdir/$_pkgname-$pkgver"
options="!check" # tests requires additional dependencies
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
done
......
......@@ -4,7 +4,7 @@ pkgname=lua-say
_rockname=say
pkgver=1.3
_pkgver=$pkgver-1
pkgrel=1
pkgrel=2
pkgdesc="Lua string hashing library, useful for internationalization"
url="https://github.com/Olivine-Labs/say"
arch="noarch"
......@@ -16,7 +16,7 @@ builddir="$srcdir/${pkgname#lua-}-$_pkgver"
# lua-say and we wanna avoid circular dependencies.
options="!check"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
done
......
......@@ -3,7 +3,7 @@
pkgname=lua-system
_pkgname=luasystem
pkgver=0.2.1
pkgrel=1
pkgrel=2
pkgdesc="Platform independent system calls for Lua"
url="https://github.com/o-lim/luasystem/"
arch="all"
......@@ -16,7 +16,7 @@ builddir="$srcdir/$_pkgname-$pkgver"
# lua-system and we wanna avoid circular dependencies.
options="!check"
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
......
......@@ -3,7 +3,7 @@
pkgname=lua-term
pkgver=0.07
_rockver=0.7-1
pkgrel=1
pkgrel=2
pkgdesc="Terminal operations for Lua"
url="https://github.com/hoelzro/lua-term"
arch="all"
......@@ -14,7 +14,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/hoelzro/$pkgname/archive/$pk
builddir="$srcdir/$pkgname-$pkgver"
options="!check" # upstream does not provide tests
_luaversions="5.1 5.2 5.3"
_luaversions="5.1 5.2 5.3 5.4"
for _v in $_luaversions; do
makedepends="$makedepends lua$_v-dev"
subpackages="$subpackages lua$_v-${pkgname#lua-}:_subpackage"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment