Commit 4a18a331 authored by J0WI's avatar J0WI Committed by Andy Postnikov
Browse files

community/vips: support more file formats

parent 6c16db83
......@@ -2,22 +2,42 @@
# Maintainer: Will Jordan <will.jordan@gmail.com>
pkgname=vips
pkgver=8.11.2
pkgrel=0
pkgrel=1
pkgdesc="fast image processing library with low memory needs"
options="!check" # oss-fuzz fails
url="http://www.vips.ecs.soton.ac.uk/"
url="https://libvips.github.io/libvips/"
# ppc64le blocked by failing test: test_seq.sh
# s390x, mips64 and riscv64 blocked by librsvg
arch="all !s390x !ppc64le !mips64 !riscv64"
arch="all !ppc64le"
license="LGPL-2.1-or-later"
makedepends="expat-dev fftw-dev giflib-dev glib-dev lcms2-dev
libexif-dev libjpeg-turbo-dev libpng-dev libwebp-dev
orc-dev tiff-dev libheif-dev gobject-introspection-dev
libimagequant-dev librsvg-dev pango-dev"
makedepends="
cfitsio-dev
expat-dev
fftw-dev
giflib-dev
glib-dev
gobject-introspection-dev
lcms2-dev
libexif-dev
libheif-dev
libimagequant-dev
libjpeg-turbo-dev
libpng-dev
libwebp-dev
openexr-dev
openjpeg-dev
orc-dev
pango-dev
poppler-dev
tiff-dev
"
checkdepends="bc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-poppler $pkgname-tools"
source="https://github.com/libvips/libvips/releases/download/v$pkgver/vips-$pkgver.tar.gz"
case "$CARCH" in
s390x|riscv64|mips64) ;;
*) makedepends="$makedepends librsvg-dev" ;;
esac
build() {
./configure \
--build=$CBUILD \
......@@ -47,6 +67,12 @@ tools() {
amove usr/bin
}
poppler() {
pkgdesc="Poppler support for $pkgname"
amove usr/lib/vips-modules-${pkgver%.*}/vips-poppler.so
}
sha512sums="
2212074a1e2fc9b18af977c32460b8f35fb3476ff302c7b05fa696c2e77d80c5beba5a3d9006a4dd27bbe00ce253518dff0e50b28098e72b516f754fffb4eae9 vips-8.11.2.tar.gz
"
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment