diff --git a/community/zabbix/APKBUILD b/community/zabbix/APKBUILD
index 17c12bfd7a5890e29bd2d8927ae086cb0742a695..23f6ce872bb67f7d02c2a737e95b9f005794890d 100644
--- a/community/zabbix/APKBUILD
+++ b/community/zabbix/APKBUILD
@@ -4,11 +4,10 @@
 # Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
 pkgname=zabbix
 pkgver=4.4.7
-pkgrel=0
+pkgrel=1
 pkgdesc="Enterprise-class open source distributed monitoring"
 url="http://www.zabbix.com"
-# go components FTBFS on mips
-arch="all !mips !mips64"
+arch="all"
 license="GPL-2.0-or-later"
 depends="fping"
 _php=php7
@@ -44,8 +43,9 @@ source="https://downloads.sourceforge.net/zabbix/zabbix-${pkgver/_/}.tar.gz
 
 builddir="$srcdir/$pkgname-${pkgver/_/}"
 
-# Agent2 does not build on x86 atm
 case $CARCH in
+mips|mips64)
+	_build_agent2=false;;
 *)
 	subpackages="$subpackages $pkgname-agent2 $pkgname-agent2-openrc:agent2_openrc"
 	makedepends="$makedepends go"