From 270bea15bc677f4b578318d21e1289dd5d07ef1c Mon Sep 17 00:00:00 2001
From: Roberto Oliveira <robertoguimaraes8@gmail.com>
Date: Thu, 26 Oct 2017 15:30:50 +0000
Subject: [PATCH] community/py3-aiohttp: fix build in not x86 architectures

Manually remove _http_parser.cpython-36m-x86_64-linux-gnu.so shared
object that is shipped in source code and make strip fails in not
x86 architectures.

Bug opened upstream: https://github.com/aio-libs/aiohttp/issues/2414
---
 community/py3-aiohttp/APKBUILD | 7 +++++++
 1 file changed, 7 insertions(+)

diff --git a/community/py3-aiohttp/APKBUILD b/community/py3-aiohttp/APKBUILD
index 1c476171bfc0..fe203ae40cb4 100644
--- a/community/py3-aiohttp/APKBUILD
+++ b/community/py3-aiohttp/APKBUILD
@@ -19,6 +19,13 @@ check() {
 	python3 setup.py check
 }
 
+prepare() {
+	default_prepare
+	# Workaround to remove x86_64 .so file that is shipped in source
+	# and make strip fails in arches != from x86_64
+	rm "$srcdir"/aiohttp-2.3.1/aiohttp/_http_parser.cpython-36m-x86_64-linux-gnu.so
+}
+
 build() {
 	cd "$builddir"
 	python3 setup.py build
-- 
GitLab