Commit 007b8dac authored by J0WI's avatar J0WI

testing/helm: security upgrade to 3.5.4

parent cda4ae51
Pipeline #81799 failed with stages
in 12 minutes and 13 seconds
# Contributor: techknowlogick <techknowlogick@gitea.io>
# Maintainer: techknowlogick <techknowlogick@gitea.io>
pkgname=helm
pkgver=3.4.2
pkgver=3.5.4
pkgrel=0
pkgdesc="The Kubernetes Package Manager"
url="https://helm.sh/"
......@@ -12,10 +12,9 @@ options="chmod-clean"
source="$pkgname-$pkgver.tar.gz::https://github.com/helm/helm/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/helm/$pkgname"
case "$CARCH" in
# Disable check on 32bit systems due to upstream test "TestPlatformPrepareCommand" that does not account for these platforms
x86|armv7) options="$options !check" ;;
esac
# secfixes:
# 3.5.4-r0:
# - CVE-2021-21303
prepare() {
mkdir -p ${builddir%/*}
......@@ -35,4 +34,4 @@ package() {
install -Dm755 bin/helm -t "$pkgdir/usr/bin"
}
sha512sums="ca0d61c270ee1b0c9a0c7627827992bec8f866f6624f37862ac2cd090919937f4cdc888f6aae9f2d1a07e032c0a3db9432cb22b33fbe49f67228641fb69f8a54 helm-3.4.2.tar.gz"
sha512sums="1ca73b493ca4d944a8ff06b9d03a03f2c118ca352c17db644403365dacd955b1ed984d74efd9c3107960f207cdf5c29c4436114ee33b94050f6306f0063a04a3 helm-3.5.4.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment