diff --git a/main/quagga/APKBUILD b/main/quagga/APKBUILD
index ba712074fe0405a238939547de0f83b86e79d295..b585f5de669e11ba121edee3f5f162f4d6aabc63 100644
--- a/main/quagga/APKBUILD
+++ b/main/quagga/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=quagga
 pkgver=0.99.22.4
-pkgrel=0
+pkgrel=1
 pkgdesc="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
 url="http://quagga.net/"
 arch="all"
@@ -13,7 +13,6 @@ subpackages="$pkgname-dev $pkgname-doc"
 pkgusers="quagga"
 pkggroups="quagga"
 source="http://download.savannah.gnu.org/releases/quagga/quagga-$pkgver.tar.xz
-	$pkgname-0.99.11-del-routes.patch
 	quagga-0.99.16-ipctl_forwarding.patch
 	bgpd.initd
 	ospf6d.initd
@@ -72,7 +71,6 @@ package() {
 	install -o quagga -g quagga -d -m755 "$pkgdir"/etc/quagga
 }
 md5sums="03ef24a448be47beba80efa2152f8a28  quagga-0.99.22.4.tar.xz
-1cbcf60a637b2577dee4d6df711e1247  quagga-0.99.11-del-routes.patch
 2328ad4066584654cfc73f66d39dc267  quagga-0.99.16-ipctl_forwarding.patch
 ec7ac8cc1103f023cf5b9482b26ece59  bgpd.initd
 92aba039c049050c48abf984c2db7e2b  ospf6d.initd
@@ -82,7 +80,6 @@ cda4115283d9f4a8304fec1b6881a7eb  ripngd.initd
 172e5b0e3f169e2b3328123e73517084  zebra.initd
 34e06a1d2bc602ce691abc9ed169dd15  zebra.confd"
 sha256sums="5e12056692e2dbc272a929f96d0e98d9873f4e7f7ffcca62434b58f6660a6386  quagga-0.99.22.4.tar.xz
-11eee48e2954f1ac47e522dee8ca6e87f486abafccfe12ee5bd0f5845077ffc5  quagga-0.99.11-del-routes.patch
 f06053e2a9030be80992bb7d4b18f4cfecd2d43cb09458557b6b8c1ac3fd22ca  quagga-0.99.16-ipctl_forwarding.patch
 962afa79a0bcb781acc4c367ed55ccea2fbb927cf1271bc1fefaffcbb2f9389a  bgpd.initd
 f1017e7681692d99eab6f9842313be18104612055bcdab14dd7ac4ac1be38f53  ospf6d.initd
@@ -92,7 +89,6 @@ fed815e6530551f314297704e5491f5d2eeb16e930dcff6f12edc88a78b6023a  ospfd.initd
 ca7c252cc1c79f05a55f933317d9a7f523dc6501bf5c72c553c43da4f8fd68dd  zebra.initd
 f7a52d383f60270a5a8fee5d4ac522c5c0ec2b7c4b5252cff54e260f32d9b323  zebra.confd"
 sha512sums="bcf429e71073e4fc71efc364a21a6c8b70871a17c66bd1328bc57b57962c2c15182436183b2e363c9c1c0e85d84c49d304d4049d40129272f52d6140db330b8a  quagga-0.99.22.4.tar.xz
-34fda1c9ccb645a3df1ccc1947f87c4086f8aadeb9b53746bfd45f3562f6c1051964b45ec3a6f7e0eb1db46e424aae3daada49fea2582a62aeff71f78b885f4b  quagga-0.99.11-del-routes.patch
 1f4c45765bc1a8678ad1404bfab65799d9329e8f78a897b5c9c294d167745dd10d25304ba490988d9e94ae815c2c6f107b13efb3c710c44515470a61e2dd7c84  quagga-0.99.16-ipctl_forwarding.patch
 a865d9f5d2593270abc56dc65785317115337da00e8f389df3bf9af314052a4dc9e8f7af1142f7726637e06f1d8f7640cafd2a9e5ee8a7b4fd6b4e7b7c5bc784  bgpd.initd
 f76aaacb1949a528a71a4bb69e9b6fa522c507000e8fa0cd60e0d80b8d2820155fa40fe7dedd86bdf38dc8029b1958c90bfbc8423afc737aae59248adba906b3  ospf6d.initd
diff --git a/main/quagga/quagga-0.99.11-del-routes.patch b/main/quagga/quagga-0.99.11-del-routes.patch
deleted file mode 100644
index 72ee89929cf16af5ad20a37d59455f5a579fbffa..0000000000000000000000000000000000000000
--- a/main/quagga/quagga-0.99.11-del-routes.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From http://lists.quagga.net/pipermail/quagga-dev/2009-January/006362.html
-
-If there are two paralell PtP links to the same router:
- C * 192.168.101.112/32 is directly connected, p1-4-19-4-20
- C>* 192.168.101.112/32 is directly connected, p1-4-17-4-18
-and the cable is to one of the ppp links is pulled, Zebra
-deletes both routes instead of just the one that got yanked.
-This fixes it to only delete the route to the interface that
-got yanked.
----
-This fix was suggested by lsorense at csclub.uwaterloo.ca (Lennart Sorensen)
-who had a similar problem. See [quagga-dev 6355]
-
- zebra/zebra_rib.c |    9 ++++++++-
- 1 files changed, 8 insertions(+), 1 deletions(-)
-
-diff --git a/zebra/zebra_rib.c b/zebra/zebra_rib.c
-index 90db932..7a37387 100644
---- a/zebra/zebra_rib.c
-+++ b/zebra/zebra_rib.c
-@@ -1896,6 +1896,13 @@ rib_delete_ipv4 (int type, int flags, struct prefix_ipv4 *p,
- 		       inet_ntoa (*gate), 
- 		       ifindex);
- 
-+  if (IS_ZEBRA_DEBUG_KERNEL && !gate)
-+    zlog_debug ("rib_delete_ipv4(): route delete %s/%d directly, %s ifindex %d",
-+		inet_ntop (AF_INET, &p->prefix, buf1, BUFSIZ),
-+		p->prefixlen,
-+		ifindex2ifname(ifindex),
-+		ifindex);
-+
-   /* Lookup route node. */
-   rn = route_node_lookup (table, (struct prefix *) p);
-   if (! rn)
-@@ -1942,7 +1949,7 @@ rib_delete_ipv4 (int type, int flags, struct prefix_ipv4 *p,
- 	  break;
- 	}
-       /* Make sure that the route found has the same gateway. */
--      else if (gate == NULL ||
-+      else if (gate != NULL &&
- 	       ((nexthop = rib->nexthop) &&
- 	        (IPV4_ADDR_SAME (&nexthop->gate.ipv4, gate) ||
- 		 IPV4_ADDR_SAME (&nexthop->rgate.ipv4, gate)))) 
-