From 1815df4c9eaa1fecc8925be90d9817ce2993999c Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 9 Dec 2013 08:53:13 +0000
Subject: [PATCH] main/wine: upgrade to 1.7.8

---
 main/wine/APKBUILD       |  14 ++--
 main/wine/freetype.patch | 162 ---------------------------------------
 2 files changed, 5 insertions(+), 171 deletions(-)
 delete mode 100644 main/wine/freetype.patch

diff --git a/main/wine/APKBUILD b/main/wine/APKBUILD
index 70c57c01e857..b8da01d85aa6 100644
--- a/main/wine/APKBUILD
+++ b/main/wine/APKBUILD
@@ -1,8 +1,8 @@
 # Maintainer: Natanael Copa <ncopa@alpinelinux.org>
 pkgname=wine
-pkgver=1.7.7
+pkgver=1.7.8
 _ver=${pkgver/_/-}
-pkgrel=2
+pkgrel=0
 pkgdesc="A compatibility layer for running Windows programs"
 url="http://www.winehq.com"
 arch="x86"
@@ -17,7 +17,6 @@ makedepends="fontconfig-dev openldap-dev libxslt-dev libxxf86dga-dev
 	tiff-dev v4l-utils-dev udisks2-dev
 	autoconf automake"
 source="http://downloads.sourceforge.net/project/wine/Source/wine-$_ver.tar.bz2
-	freetype.patch
 	"
 
 _builddir="$srcdir"/$pkgname-$_ver
@@ -54,9 +53,6 @@ package() {
 		"$pkgdir"/usr/bin/wine
 }
 
-md5sums="e3b9383439d60202b10b5e93e5b00a3b  wine-1.7.7.tar.bz2
-04de15acbaea8e336f267e14efd1cd9b  freetype.patch"
-sha256sums="110603b6bff33441356ef6e72f94a70abf3b4822be1f0fb6c84b5240e9d5aca7  wine-1.7.7.tar.bz2
-99715e726c0fdbe879fd42254670dfac60319fcd20c4593f5ed085b8dbf8584e  freetype.patch"
-sha512sums="94a4bb48261b575f7f8c8e1d6b54192dbf35b9aa595fb5afd571458cc94af2b72591facb32e7777e1ceb650a3567a3708089ab363d20b0cc4fc4984e31accb52  wine-1.7.7.tar.bz2
-352e5b14e08fd9343556efb44d044b5c4eabda27f55ec1f4458628ea4177d75843739c5bf6920a69eb8d3ceea58f3f38984c97040e4e7e150e769ddd17c52050  freetype.patch"
+md5sums="e66a9d73e224c099b617a1f5d718d604  wine-1.7.8.tar.bz2"
+sha256sums="30e17f5f863a09416f3d229666566b318dbb40f683d4ca6630012c60bb511804  wine-1.7.8.tar.bz2"
+sha512sums="1fdaddb7909f818050854bf351d20f445cf6a5906b1bcc789c96ee8d5058c90815a91bbbc6444f3e4527748764f03ab5297585c174b433093a3354a827402fea  wine-1.7.8.tar.bz2"
diff --git a/main/wine/freetype.patch b/main/wine/freetype.patch
deleted file mode 100644
index 08fd3cb9e410..000000000000
--- a/main/wine/freetype.patch
+++ /dev/null
@@ -1,162 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 98a73f2..56bc8ce 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -1466,27 +1466,27 @@ then
-         [WINE_CHECK_SONAME(freetype,FT_Init_FreeType,[ft_lib=yes],[ft_lib=no],[$FREETYPE_LIBS])
-         if test "$ft_lib" = "yes"
-         then
--    	AC_CHECK_HEADERS(ft2build.h \
--                             freetype/freetype.h \
--                             freetype/ftglyph.h \
--                             freetype/fttypes.h \
--                             freetype/tttables.h \
--                             freetype/ftsnames.h \
--                             freetype/ttnameid.h \
--                             freetype/ftoutln.h \
--                             freetype/ftwinfnt.h \
--                             freetype/ftmodapi.h \
--                             freetype/ftlcdfil.h,,,
-+        AC_CHECK_HEADERS(ft2build.h \
-+                             freetype.h \
-+                             ftglyph.h \
-+                             fttypes.h \
-+                             tttables.h \
-+                             ftsnames.h \
-+                             ttnameid.h \
-+                             ftoutln.h \
-+                             ftwinfnt.h \
-+                             ftmodapi.h \
-+                             ftlcdfil.h,,,
-                              [#ifdef HAVE_FT2BUILD_H
- # include <ft2build.h>
- #endif])
--    	AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <ft2build.h>
--#include <freetype/fttrigon.h>]])],[AC_DEFINE(HAVE_FREETYPE_FTTRIGON_H, 1,
--              [Define if you have the <freetype/fttrigon.h> header file.])
-+        AC_PREPROC_IFELSE([AC_LANG_SOURCE([[#include <ft2build.h>
-+#include <fttrigon.h>]])],[AC_DEFINE(HAVE_FTTRIGON_H, 1,
-+              [Define if you have the <fttrigon.h> header file.])
-                         wine_cv_fttrigon=yes],[wine_cv_fttrigon=no])
--            AC_CHECK_TYPES(FT_TrueTypeEngineType,,,[#include <freetype/ftmodapi.h>])
--    	dnl Check that we have at least freetype/freetype.h
--    	if test "$ac_cv_header_freetype_freetype_h" = "yes" -a "$wine_cv_fttrigon" = "yes"
-+            AC_CHECK_TYPES([FT_TrueTypeEngineType],,,[#include <ftmodapi.h>])
-+        dnl Check that we have at least freetype.h
-+        if test "$ac_cv_header_freetype_h" = "yes" -a "$wine_cv_fttrigon" = "yes"
-     	then
-     	    AC_DEFINE(HAVE_FREETYPE, 1, [Define if FreeType 2 is installed])
-             else
-@@ -1496,9 +1496,9 @@ then
-             FREETYPE_LIBS=""
-         fi])
- fi
--WINE_ERROR_WITH(freetype,[test "x$ac_cv_header_freetype_freetype_h" != xyes -o "x$wine_cv_fttrigon" != xyes],
-+WINE_ERROR_WITH(freetype,[test "x$ac_cv_header_freetype_h" != xyes -o "x$wine_cv_fttrigon" != xyes],
-                 [FreeType ${notice_platform}development files not found. Fonts will not be built.])
--test "x$ac_cv_header_freetype_freetype_h" = xyes -a "x$wine_cv_fttrigon" = xyes || enable_fonts=${enable_fonts:-no}
-+test "x$ac_cv_header_freetype_h" = xyes -a "x$wine_cv_fttrigon" = xyes || enable_fonts=${enable_fonts:-no}
- 
- dnl **** Check for parport (currently Linux only) ****
- AC_CACHE_CHECK([for parport header/ppdev.h], ac_cv_c_ppdev,
-diff --git a/dlls/gdi32/freetype.c b/dlls/gdi32/freetype.c
-index fb4f2af..517f985 100644
---- a/dlls/gdi32/freetype.c
-+++ b/dlls/gdi32/freetype.c
-@@ -98,38 +98,38 @@ WINE_DEFAULT_DEBUG_CHANNEL(font);
- #ifdef HAVE_FT2BUILD_H
- #include <ft2build.h>
- #endif
--#ifdef HAVE_FREETYPE_FREETYPE_H
--#include <freetype/freetype.h>
-+#ifdef HAVE_FREETYPE_H
-+#include <freetype.h>
- #endif
--#ifdef HAVE_FREETYPE_FTGLYPH_H
--#include <freetype/ftglyph.h>
-+#ifdef HAVE_FTGLYPH_H
-+#include <ftglyph.h>
- #endif
--#ifdef HAVE_FREETYPE_TTTABLES_H
--#include <freetype/tttables.h>
-+#ifdef HAVE_TTTABLES_H
-+#include <tttables.h>
- #endif
--#ifdef HAVE_FREETYPE_FTTYPES_H
--#include <freetype/fttypes.h>
-+#ifdef HAVE_FTTYPES_H
-+#include <fttypes.h>
- #endif
--#ifdef HAVE_FREETYPE_FTSNAMES_H
--#include <freetype/ftsnames.h>
-+#ifdef HAVE_FTSNAMES_H
-+#include <ftsnames.h>
- #endif
--#ifdef HAVE_FREETYPE_TTNAMEID_H
--#include <freetype/ttnameid.h>
-+#ifdef HAVE_TTNAMEID_H
-+#include <ttnameid.h>
- #endif
--#ifdef HAVE_FREETYPE_FTOUTLN_H
--#include <freetype/ftoutln.h>
-+#ifdef HAVE_FTOUTLN_H
-+#include <ftoutln.h>
- #endif
--#ifdef HAVE_FREETYPE_FTTRIGON_H
--#include <freetype/fttrigon.h>
-+#ifdef HAVE_FTTRIGON_H
-+#include <fttrigon.h>
- #endif
--#ifdef HAVE_FREETYPE_FTWINFNT_H
--#include <freetype/ftwinfnt.h>
-+#ifdef HAVE_FTWINFNT_H
-+#include <ftwinfnt.h>
- #endif
--#ifdef HAVE_FREETYPE_FTMODAPI_H
--#include <freetype/ftmodapi.h>
-+#ifdef HAVE_FTMODAPI_H
-+#include <ftmodapi.h>
- #endif
--#ifdef HAVE_FREETYPE_FTLCDFIL_H
--#include <freetype/ftlcdfil.h>
-+#ifdef HAVE_FTLCDFIL_H
-+#include <ftlcdfil.h>
- #endif
- 
- #ifndef HAVE_FT_TRUETYPEENGINETYPE
-@@ -186,7 +186,7 @@ MAKE_FUNCPTR(FT_Vector_Transform);
- MAKE_FUNCPTR(FT_Vector_Unit);
- static FT_Error (*pFT_Outline_Embolden)(FT_Outline *, FT_Pos);
- static FT_TrueTypeEngineType (*pFT_Get_TrueType_Engine_Type)(FT_Library);
--#ifdef HAVE_FREETYPE_FTLCDFIL_H
-+#ifdef HAVE_FTLCDFIL_H
- static FT_Error (*pFT_Library_SetLcdFilter)(FT_Library, FT_LcdFilter);
- #endif
- 
-@@ -924,7 +924,7 @@ static BOOL is_hinting_enabled(void)
- 
- static BOOL is_subpixel_rendering_enabled( void )
- {
--#ifdef HAVE_FREETYPE_FTLCDFIL_H
-+#ifdef HAVE_FTLCDFIL_H
-     static int enabled = -1;
-     if (enabled == -1)
-     {
-@@ -3918,7 +3918,7 @@ static BOOL init_freetype(void)
-     /* Don't warn if these ones are missing */
-     pFT_Outline_Embolden = wine_dlsym(ft_handle, "FT_Outline_Embolden", NULL, 0);
-     pFT_Get_TrueType_Engine_Type = wine_dlsym(ft_handle, "FT_Get_TrueType_Engine_Type", NULL, 0);
--#ifdef HAVE_FREETYPE_FTLCDFIL_H
-+#ifdef HAVE_FTLCDFIL_H
-     pFT_Library_SetLcdFilter = wine_dlsym(ft_handle, "FT_Library_SetLcdFilter", NULL, 0);
- #endif
- 
-@@ -6706,7 +6706,7 @@ static DWORD get_glyph_outline(GdiFont *incoming_font, UINT glyph, UINT format,
-     case WINE_GGO_HBGR_BITMAP:
-     case WINE_GGO_VRGB_BITMAP:
-     case WINE_GGO_VBGR_BITMAP:
--#ifdef HAVE_FREETYPE_FTLCDFIL_H
-+#ifdef HAVE_FTLCDFIL_H
-       {
-         switch (ft_face->glyph->format)
-         {
-- 
GitLab