From 16efb1508c794f2eb5e74ef4584d3245f7f108c4 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 11 Dec 2013 12:37:49 +0000
Subject: [PATCH] main/open-vm-tools-grsec: disable as it does not build on
 3.12

---
 main/open-vm-tools-grsec/APKBUILD             |  4 +-
 ...hgfs-d_count-kernel-3.11-tools-9.6.0.patch | 40 +++++++++++++++++++
 2 files changed, 42 insertions(+), 2 deletions(-)
 create mode 100644 main/open-vm-tools-grsec/vmhgfs-d_count-kernel-3.11-tools-9.6.0.patch

diff --git a/main/open-vm-tools-grsec/APKBUILD b/main/open-vm-tools-grsec/APKBUILD
index b0c04d74740b..58e529ae5e5a 100644
--- a/main/open-vm-tools-grsec/APKBUILD
+++ b/main/open-vm-tools-grsec/APKBUILD
@@ -3,7 +3,7 @@
 _flavor=grsec
 _kpkg=linux-$_flavor
 _realname=open-vm-tools
-_kver=3.10.23
+_kver=3.12.4
 _kpkgrel=0
 
 _realver=9.4.0_p1280544
@@ -33,7 +33,7 @@ pkgrel=$(($_kpkgrel + $_mypkgrel))
 
 pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
 url="http://open-vm-tools.sourceforge.net/"
-arch="all"
+arch=""
 license="LGPL"
 subpackages=""
 depends="linux-${_flavor}=${_kernelver}"
diff --git a/main/open-vm-tools-grsec/vmhgfs-d_count-kernel-3.11-tools-9.6.0.patch b/main/open-vm-tools-grsec/vmhgfs-d_count-kernel-3.11-tools-9.6.0.patch
new file mode 100644
index 000000000000..68294794d9aa
--- /dev/null
+++ b/main/open-vm-tools-grsec/vmhgfs-d_count-kernel-3.11-tools-9.6.0.patch
@@ -0,0 +1,40 @@
+--- a/modules/linux/vmhgfs/inode.c	2013-08-15 22:32:22.000000000 -0700
++++ b/modules/linux/vmhgfs/inode.c	2013-09-16 21:31:12.323041668 -0700
+@@ -31,6 +31,9 @@
+ #include <linux/namei.h>
+ #endif
+ #include <linux/highmem.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++#include <linux/dcache.h>
++#endif
+
+ #include "compat_cred.h"
+ #include "compat_fs.h"
+@@ -1890,7 +1893,11 @@
+ #endif
+                            &inode->i_dentry,
+                            d_alias) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++         int dcount = d_count(dentry);
++#else
+          int dcount = dentry->d_count;
++#endif
+          if (dcount) {
+             LOG(4, ("Found %s %d \n", dentry->d_name.name, dcount));
+             return HgfsAccessInt(dentry, mask & (MAY_READ | MAY_WRITE | MAY_EXEC));
+@@ -1943,10 +1950,12 @@
+       list_for_each(pos, &inode->i_dentry) {
+          int dcount;
+          struct dentry *dentry = list_entry(pos, struct dentry, d_alias);
+-#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 38)
+-         dcount = atomic_read(&dentry->d_count);
+-#else
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 11, 0)
++         dcount = d_count(dentry);
++#elif LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 38)
+          dcount = dentry->d_count;
++#else
++         dcount = atomic_read(&dentry->d_count);
+ #endif
+          if (dcount) {
+             LOG(4, ("Found %s %d \n", (dentry)->d_name.name, dcount));
-- 
GitLab