main/apk-tools: depend on musl >=1.2

Musl 1.2 introduced new ABI for time64 => upgrading apk-tools
while staying on musl <1.2 causes missing symbols
7 jobs for !11041 with apk-tools in 23 seconds
detached
Status Job ID Name Coverage
  Lint
failed #178989
x86_64 docker-alpine allowed to fail
lint

00:00:08

 
  Build
failed #178994
aarch64 ci-build docker-alpine
build-aarch64

00:00:06

failed #178995
armv7 ci-build docker-alpine
build-armv7

00:00:08

failed #178993
ppc64le ci-build docker-alpine
build-ppc64le

00:00:14

failed #178992
s390x ci-build docker-alpine
build-s390x

failed #178991
x86 ci-build docker-alpine
build-x86

00:00:07

failed #178990
x86_64 ci-build docker-alpine
build-x86_64

00:00:07

 
Name Stage Failure
failed
build-s390x Build There has been a timeout failure or the job got stuck. Check your timeout limits or try again
No job log
failed
build-ppc64le Build
No job log
failed
build-x86_64 Build
No job log
failed
build-x86 Build
No job log
failed
build-armv7 Build
No job log
failed
build-aarch64 Build
No job log
failed
lint Lint
No job log