Commit 3b516609 authored by J0WI's avatar J0WI Committed by Natanael Copa

testing: (Bulk change) Update source urls to https using HTTPS Everywhere

parent 0ed5524b
......@@ -11,7 +11,7 @@ depends=""
depends_dev="glib-dev gobject-introspection-dev polkit-dev"
makedepends="$depends_dev intltool gnome-doc-utils"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://www.freedesktop.org/software/accountsservice/accountsservice-$pkgver.tar.xz
source="https://www.freedesktop.org/software/accountsservice/accountsservice-$pkgver.tar.xz
musl-fgetspent_r.patch
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -13,7 +13,7 @@ depends="apache2"
depends_dev="$pkgname"
makedepends="apache2-dev perl-dev perl-linux-pid apr-dev apr-util-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="http://www-eu.apache.org/dist/perl/$_pkgreal-$pkgver.tar.gz
source="https://www-eu.apache.org/dist/perl/$_pkgreal-$pkgver.tar.gz
$pkgname.conf"
builddir="$srcdir/$_pkgreal-$pkgver"
......
......@@ -7,7 +7,7 @@ url="http://git.alpinelinux.org/cgit/user/ncopa/aports-ghpr"
arch="all"
license="ISC"
makedepends="go dep"
source="http://dev.alpinelinux.org/archive/aports-ghpr/aports-ghpr-$pkgver.tar.xz
source="https://dev.alpinelinux.org/archive/aports-ghpr/aports-ghpr-$pkgver.tar.xz
add-toml-file.patch"
builddir="$srcdir/src/github.com/aports-ghpr/$pkgname"
options="!check"
......
......@@ -11,7 +11,7 @@ depends="php7"
depends="php7 php7-curl php-json libphutil"
options="!check" # no checks
subpackages=""
source="http://dev.alpinelinux.org/archive/arcanist/arcanist-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/arcanist/arcanist-$pkgver.tar.gz"
builddir="$srcdir/arcanist-stable"
build() {
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="perl"
install=""
subpackages="$pkgname-doc"
source="http://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://savannah.nongnu.org/download/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
......
......@@ -11,7 +11,7 @@ depends_dev=""
makedepends="$depends_dev linux-headers"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://dev.alpinelinux.org/archive/aufs-util/aufs-util-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/aufs-util/aufs-util-$pkgver.tar.gz
0001-implement-glibc-compatible-nftw-if-libc-does-not-pro.patch
0002-add-aufs_type.h-from-linux-header.patch
0003-make-install-compatible-with-busybox-install.patch
......
......@@ -9,7 +9,7 @@ arch="noarch"
license="GPL"
depends="python2 rsync py2-argcomplete py2-dateutil py2-psycopg2 py-argh"
subpackages="$pkgname-doc"
source="http://sourceforge.net/projects/pgbarman/files/${pkgver}/barman-${pkgver}.tar.gz"
source="https://sourceforge.net/projects/pgbarman/files/${pkgver}/barman-${pkgver}.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -13,7 +13,7 @@ depends="boost-dev"
makedepends=""
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/boostorg/${pkgname#*-}/archive/${pkgname%%-*}-$pkgver.tar.gz
$pkgname-$pkgver-LICENSE.txt::http://boost.org/LICENSE_1_0.txt"
$pkgname-$pkgver-LICENSE.txt::https://boost.org/LICENSE_1_0.txt"
builddir="$srcdir/${pkgname#*-}-${pkgname%%-*}-$pkgver"
build() {
......
......@@ -13,7 +13,7 @@ depends_dev="libsigsegv-dev ffcall ncurses-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
no-page.h.patch"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -10,7 +10,7 @@ url="https://developers.google.com/closure/compiler/"
arch="noarch !s390x"
license="Apache-2.0"
depends="openjdk8-jre-base"
source="$pkgname-$pkgver-jar.tar.gz::http://dl.google.com/$pkgname/compiler-$pkgver.tar.gz
source="$pkgname-$pkgver-jar.tar.gz::https://dl.google.com/$pkgname/compiler-$pkgver.tar.gz
$pkgname"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -10,7 +10,7 @@ depends=""
makedepends=""
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/cntlm/cntlm/cntlm%20$pkgver/cntlm-$pkgver.tar.gz
source="https://downloads.sourceforge.net/project/cntlm/cntlm/cntlm%20$pkgver/cntlm-$pkgver.tar.gz
cntlm.initd
"
builddir="$srcdir"/cntlm-$pkgver
......
......@@ -13,7 +13,7 @@ depends=""
depends_dev="$pkgname"
makedepends=""
subpackages="$pkgname-dev"
source="http://www.cryptopp.com/${_pkgname}${_pkgver}.zip"
source="https://www.cryptopp.com/${_pkgname}${_pkgver}.zip"
builddir="$srcdir"
......
......@@ -10,7 +10,7 @@ depends=
# The makefile need GNU cat for 'cat -v'
makedepends="coreutils"
source="http://cr.yp.to/daemontools/$pkgname-$pkgver.tar.gz
source="https://cr.yp.to/daemontools/$pkgname-$pkgver.tar.gz
0.76-errno.patch
0.76-warnings.patch
svscan.initd
......
......@@ -8,7 +8,7 @@ pkgdesc="command-line text/math procesing"
url="https://www.gnu.org/software/datamash/"
arch="all"
license="GPL"
source="http://ftpmirror.gnu.org/datamash/$pkgname-$pkgver.tar.gz"
source="https://ftpmirror.gnu.org/datamash/$pkgname-$pkgver.tar.gz"
subpackages="$pkgname-doc $pkgname-bash-completion:bashcomp:noarch"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends=""
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://www.fefe.de/$pkgname/$pkgname-$pkgver.tar.bz2"
source="https://www.fefe.de/$pkgname/$pkgname-$pkgver.tar.bz2"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL-3.0"
makedepends="autoconf automake bind-dev libtool libressl-dev perl-graphviz perl-crypt-openssl-random
perl-net-dns perl-net-dns-sec perl-xml-simple perl-dev sed chrpath"
source="http://dev.alpinelinux.org/archive/dnssec-tools/dnssec-tools-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/dnssec-tools/dnssec-tools-$pkgver.tar.gz"
subpackages="$pkgname-dev $pkgname-doc"
builddir="${srcdir}/${pkgname}-${pkgver}"
......
......@@ -7,7 +7,7 @@ url="https://github.com/jwilder/dockerize"
arch="x86 x86_64 ppc64le"
license="MIT"
makedepends="git go"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar"
_giturl="git://github.com/jwilder/${pkgname}.git"
_disturl="dev.alpinelinux.org:/archive/$pkgname/"
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL"
makedepends="libdvdread-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/dvdbackup/dvdbackup-$pkgver.tar.xz"
source="https://downloads.sourceforge.net/dvdbackup/dvdbackup-$pkgver.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
prepare() {
......
......@@ -8,7 +8,7 @@ url="http://www.dynagen.org/"
arch="noarch"
license="GPL-2.0"
depends="dynamips python2"
source="http://downloads.sourceforge.net/dyna-gen/${pkgname}-${pkgver}.tar.gz
source="https://downloads.sourceforge.net/dyna-gen/${pkgname}-${pkgver}.tar.gz
etc-path.patch"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -12,7 +12,7 @@ depends_dev="cmake libxml2-dev libzip-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
10-cmake_libzip_zipconf_path.patch"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -14,7 +14,7 @@ makedepends="$depends_dev gperf flex bison glib-dev gtk+3.0-dev libsecret-dev
openldap-dev libgdata-dev json-glib-dev webkit2gtk-dev libgweather-dev
cmake libical-dev libcanberra-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="http://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.xz"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-${pkgver}.tar.xz"
builddir="${srcdir}/${pkgname}-${pkgver}"
prepare() {
......
......@@ -11,7 +11,7 @@ depends=""
makedepends="flex-dev"
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
_builddir="$srcdir"/$pkgname-$pkgver
build() {
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL-2.0"
makedepends="automake autoconf parted-dev e2fsprogs-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2
source="https://downloads.sourceforge.net/project/${pkgname}/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.bz2
fatresize-1.0.2-libparted_ver_check.patch
fatresize-1.0.2-ped_free.patch
fatresize-1.0.2-ped_assert.patch"
......
......@@ -13,7 +13,7 @@ makedepends="$depends_dev boost-dev cmake curl-dev dbus-dev eudev-dev
qt5-qtdeclarative-dev simgear zlib-dev"
install="$pkgname.post-install"
subpackages="$pkgname-doc $pkgname-dbg"
source="http://downloads.sourceforge.net/project/$pkgname/release-${pkgver%.[1-9]*}/$pkgname-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/project/$pkgname/release-${pkgver%.[1-9]*}/$pkgname-$pkgver.tar.bz2
musl-fixes.patch
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -10,7 +10,7 @@ arch="all"
license="GPL-2.0-only FreeImage"
makedepends="dos2unix"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/${pkgname}/${_pkgname}${pkgver//.}.zip
source="https://downloads.sourceforge.net/${pkgname}/${_pkgname}${pkgver//.}.zip
0001-no-root-install.patch
0002-fix-cpuid-x86.patch
0005-makefile-gnu.patch"
......
......@@ -12,7 +12,7 @@ depends=""
makedepends="doxygen"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/gmerlin/gavl-$pkgver.tar.gz
source="https://downloads.sourceforge.net/sourceforge/gmerlin/gavl-$pkgver.tar.gz
musl-sched_h.patch"
prepare() {
......
......@@ -7,7 +7,7 @@ url="http://www.gnu.org/software/libiconv"
arch="all"
license='LGPL'
depends=""
source="http://ftp.gnu.org/pub/gnu/libiconv/libiconv-$pkgver.tar.gz"
source="https://ftp.gnu.org/pub/gnu/libiconv/libiconv-$pkgver.tar.gz"
subpackages="$pkgname-doc $pkgname-dev"
builddir="$srcdir"/libiconv-$pkgver
......
......@@ -4,13 +4,13 @@ _pkgname=goconf
_vendor=dlintw
pkgver=0_git20170102
pkgrel=2
pkgdesc="goconf package - fork from http://code.google.com/p/goconf/"
pkgdesc="goconf package - fork from https://code.google.com/p/goconf/"
url="https://github.com/$_vendor/$_pkgname"
arch="noarch"
license="BSD-3-Clause"
depends="go"
subpackages="$pkgname-doc"
source="http://dev.alpinelinux.org/archive/$_pkgname/$_pkgname-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/$_pkgname/$_pkgname-$pkgver.tar.gz"
giturl="https://github.com/dlintw/$_pkgname.git"
disturl="larena@dev.alpinelinux.org:/archive/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev enchant-dev gtk+3.0-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/gtkspell/gtkspell3-$pkgver.tar.xz"
source="https://downloads.sourceforge.net/gtkspell/gtkspell3-$pkgver.tar.xz"
builddir="$srcdir/gtkspell3-$pkgver"
build() {
......
......@@ -14,7 +14,7 @@ makedepends="$depends_dev cups-dev tiff-dev libjpeg-turbo-dev libpng-dev
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs
$pkgname-cups $pkgname-samples"
source="http://downloads.sourceforge.net/gimp-print/gutenprint-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/gimp-print/gutenprint-$pkgver.tar.bz2
musl-fix-header.patch
pagesize-name-clash.patch
gutenprint-O6.patch
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev linux-headers perl-dev python-dev swig tcl-dev chrpath"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-perl $pkgname-python $pkgname-tcl"
source="http://downloads.sourceforge.net/project/hamlib/hamlib/3.0/hamlib-3.0.tar.gz"
source="https://downloads.sourceforge.net/project/hamlib/hamlib/3.0/hamlib-3.0.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
build() {
......
......@@ -13,7 +13,7 @@ depends_dev=""
makedepends="$depends_dev python2 bison python2-dev swig"
install=""
subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
missing_unistd_include.patch"
_builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -12,7 +12,7 @@ license="GPL"
depends=""
makedepends="libjpeg-turbo-dev net-snmp-dev cups-dev libusb-dev sane-dev"
subpackages="$pkgname-doc $pkgname-libs sane-backend-hpaio:sane"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
fix-includes.patch"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev linux-headers py-setuptools python2-dev"
install=
subpackages="$pkgname-dev $pkgname-doc py-smbus:py"
source="http://fossies.org/linux/misc/$pkgname-$pkgver.tar.gz"
source="https://fossies.org/linux/misc/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -16,8 +16,8 @@ makedepends="cmake
llvm-static>=$_llvmver"
checkdepends="lit"
subpackages="$pkgname-dev"
source="http://releases.llvm.org/$pkgver/libcxx-$pkgver.src.tar.xz
http://releases.llvm.org/$pkgver/libcxxabi-$pkgver.src.tar.xz
source="https://releases.llvm.org/$pkgver/libcxx-$pkgver.src.tar.xz
https://releases.llvm.org/$pkgver/libcxxabi-$pkgver.src.tar.xz
check-for-musl-libcs-max_align_t.patch
avoid-strtoll_l.patch
disable-broken-tests.patch
......
......@@ -12,7 +12,7 @@ depends_dev="tiff-dev cairo-dev libexif-dev glib-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://download.mono-project.com/sources/libgdiplus/libgdiplus-$pkgver.tar.gz"
source="https://download.mono-project.com/sources/libgdiplus/libgdiplus-$pkgver.tar.gz"
_builddir="$srcdir"/libgdiplus-$pkgver
prepare() {
......
......@@ -11,7 +11,7 @@ makedepends="automake autoconf libtool intltool libimobiledevice-dev libplist-de
swig py-gobject-dev mutagen sg3_utils-dev gdk-pixbuf-dev
glib-dev sqlite-dev gobject-introspection-dev libxml2-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/project/gtkpod/$pkgname/$pkgname-0.8/$pkgname-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/project/gtkpod/$pkgname/$pkgname-0.8/$pkgname-$pkgver.tar.bz2
0001-323-Segmentation-fault-when-opening-ipod.patch
0002-Fix-spelling-errors-in-comments-and-strings-using-co.patch
0003-Fixed-PList-deprecation.patch
......
......@@ -10,7 +10,7 @@ license="GPL-2.0"
depends_dev="py-$pkgname"
makedepends="file python2-dev"
subpackages="$pkgname-dev $pkgname-doc py-$pkgname:_py"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.bz2
include.patch"
builddir="$srcdir/$pkgname-$pkgver"
options="!check"
......
......@@ -10,7 +10,7 @@ license="Apache-2.0"
depends="php7 php7-curl php-json"
options="!check" # no checks
subpackages=""
source="http://dev.alpinelinux.org/archive/libphutil/libphutil-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/libphutil/libphutil-$pkgver.tar.gz"
builddir="$srcdir/libphutil-stable"
build() {
......
......@@ -8,7 +8,7 @@ url="http://www.gnu.org/software/libsigsegv/"
arch="all"
license="GPL-2.0"
subpackages="$pkgname-dev"
source="http://ftp.gnu.org/gnu/libsigsegv/libsigsegv-$pkgver.tar.gz
source="https://ftp.gnu.org/gnu/libsigsegv/libsigsegv-$pkgver.tar.gz
0001-Avoid-use-of-glibc-internal-macros.patch
"
......
......@@ -12,7 +12,7 @@ depends_dev=
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2"
source="https://downloads.sourceforge.net/sourceforge/pupnp/${pkgname}-${pkgver}.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -8,7 +8,7 @@ arch="all"
license="GPL-2.0-or-later"
makedepends="linux-headers sdl-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/linuxconsole/linuxconsoletools-$pkgver.tar.bz2"
source="https://downloads.sourceforge.net/linuxconsole/linuxconsoletools-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -26,7 +26,7 @@ makedepends="
swig
"
subpackages="$pkgname-dev py2-$pkgname:py2"
source="http://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz
source="https://llvm.org/releases/$pkgver/$pkgname-$pkgver.src.tar.xz
musl-include-ptrace.aarch64.patch
cmake-include-ClangConfig.patch
fix-embedded_interpreter.patch
......
......@@ -8,7 +8,7 @@ url="http://log4cpp.sourceforge.net/"
arch="all"
license="LGPL-2.1-or-later"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname"
prepare() {
......
......@@ -13,7 +13,7 @@ depends_dev=
makedepends=
install=
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/project/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
package() {
cd "$srcdir"/$pkgname-$pkgver
......
......@@ -11,7 +11,7 @@ url='http://lxde.org/'
makedepends='gtk+2.0-dev lxappearance-dev openbox-dev intltool'
options='libtool'
subpackages="$pkgname-lang"
source="http://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz
source="https://downloads.sourceforge.net/lxde/$pkgname-$pkgver.tar.gz
obconf-rrbutton.patch"
prepare() {
......
......@@ -12,7 +12,7 @@ makedepends='gtk+2.0-dev alsa-lib-dev menu-cache-dev libwnck-dev
wireless-tools-dev docbook-xml docbook-xsl intltool libfm-dev
linux-headers libxml2-dev keybinder-dev'
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
source="http://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.xz
source="https://downloads.sourceforge.net/sourceforge/lxde/$pkgname-$pkgver.tar.xz
10-devproc-lxpanel-0.6.2.patch"
builddir="$srcdir"/${pkgname}-${pkgver}
......
......@@ -8,7 +8,7 @@ url="http://www.nongnu.org/lzip/lzlib.html"
arch="all"
license="GPL-2.0-or-later"
subpackages="$pkgname-doc"
source="http://download.savannah.gnu.org/releases/lzip/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://download.savannah.gnu.org/releases/lzip/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -8,7 +8,7 @@ url="https://github.com/miconda/md5ha1"
arch="all"
license="MIT"
options="!check"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
disturl="dev.alpinelinux.org:/archive/$pkgname"
giturl="https://github.com/miconda/md5ha1.git"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL"
makedepends="ncurses-dev texinfo"
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/moe/moe-$pkgver.tar.lz"
source="https://ftp.gnu.org/gnu/moe/moe-$pkgver.tar.lz"
options="!check"
builddir="$srcdir/"$pkgname-$pkgver
......
......@@ -12,7 +12,7 @@ depends="python2"
depends_dev="zlib-dev libgdiplus-dev"
makedepends="$depends_dev python2 linux-headers paxmark autoconf automake libtool cmake"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2"
source="https://download.mono-project.com/sources/mono/mono-${pkgver/_/~}.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
......
......@@ -9,7 +9,7 @@ license="GPL"
depends=""
makedepends=""
install=""
source="http://dev.alpinelinux.org/archive/nbtscan/${pkgname}_$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/nbtscan/${pkgname}_$pkgver.tar.gz"
subpackages="$pkgname-dbg"
options="!check"
......
......@@ -39,7 +39,7 @@ pkggroups="$_grp_ngx $_grp_www"
install="$pkgname.pre-install $pkgname.pre-upgrade"
options="!check"
subpackages="$pkgname-doc"
source="http://nginx.org/download/$_pkgname-$pkgver.tar.gz
source="https://nginx.org/download/$_pkgname-$pkgver.tar.gz
naxsi-$_ngx_naxsi_ver.tar.gz::https://github.com/nbs-system/$_ngx_naxsi_name/archive/$_ngx_naxsi_ver.tar.gz
ngx_cache_purge-$_ngx_cache_purge_ver.tar.gz::https://github.com/itoffshore/$_ngx_cache_purge_name/archive/v$_ngx_cache_purge_ver.tar.gz
upstream-fair-$_ngx_upstream_fair_ver.tar.gz::https://github.com/itoffshore/$_ngx_upstream_fair_name/archive/v$_ngx_upstream_fair_ver.tar.gz
......
......@@ -13,7 +13,7 @@ depends_dev=""
makedepends="linux-headers"
install=""
subpackages="$pkgname-doc"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
${pkgname}.initd
${pkgname}-trigger.initd
......
......@@ -13,7 +13,7 @@ depends_dev=""
makedepends="linux-headers"
install=""
subpackages="$pkgname-doc"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
disturl="dev.alpinelinux.org:/archive/$pkgname"
reporev="5881cff90359800b1d01ebc0bf35f53f4a67815d"
......
......@@ -11,7 +11,7 @@ license="GPL-2.0-or-later"
makedepends="vlc-dev automake autoconf libtool npapi-sdk libx11-dev libxcb-dev
gtk+2.0-dev"
source="https://code.videolan.org/videolan/npapi-vlc/-/archive/$pkgver/npapi-vlc-${pkgver}.tar.bz2
http://dev.alpinelinux.org/archive/$pkgname/libvlcpp-${_pkglibver}.tar.gz
https://dev.alpinelinux.org/archive/$pkgname/libvlcpp-${_pkglibver}.tar.gz
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -16,7 +16,7 @@ makedepends="autoconf automake curl-dev geoip-dev glib-dev hiredis-dev
linux-headers mariadb-connector-c-dev"
install="$pkgname.pre-install"
#subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/ntop/$pkgname/$pkgname-$pkgver-stable.tar.gz
source="https://downloads.sourceforge.net/project/ntop/$pkgname/$pkgname-$pkgver-stable.tar.gz
$pkgname.initd
$pkgname.confd
ntopng-update-geoip-db
......
......@@ -12,7 +12,7 @@ makedepends=""
install=""
subpackages="numix-light-icon-theme:numix_light"
options="!strip"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz"
giturl="https://github.com/numixproject/numix-icon-theme.git"
disturl="dev.alpinelinux.org:/archive/$pkgname"
......
......@@ -10,7 +10,7 @@ license="various"
depends="perl cvs diffutils"
makedepends="linux-pam-dev libxml2-dev xmlsec-dev autoconf automake libtool gtk-doc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-liboath $pkgname-libpskc $pkgname-oathtool $pkgname-pam_oath"
source="http://download.savannah.gnu.org/releases/oath-toolkit/oath-toolkit-${pkgver}.tar.gz"
source="https://download.savannah.gnu.org/releases/oath-toolkit/oath-toolkit-${pkgver}.tar.gz"
builddir="oath-toolkit-${pkgver}"
build() {
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="libftdi1-dev libusb-dev hidapi-dev libtool"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
source="https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -11,7 +11,7 @@ depends="linux-pam"
makedepends="$depends_dev linux-pam-dev"
install=""
subpackages="$pkgname-doc"
source="http://netix.dl.sourceforge.net/project/pamtester/pamtester/0.1.2/pamtester-0.1.2.tar.gz"
source="https://netix.dl.sourceforge.net/project/pamtester/pamtester/0.1.2/pamtester-0.1.2.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -29,7 +29,7 @@ depends="
"
subpackages="$pkgname-openrc"
options="!check" # no checks
source="http://dev.alpinelinux.org/archive/phabricator/phabricator-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/phabricator/phabricator-$pkgver.tar.gz
phd.initd
"
builddir="$srcdir/phabricator-stable"
......
......@@ -11,7 +11,7 @@ arch="all"
license="PHP"
depends=""
makedepends="php7-dev autoconf"
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$_pkgver
build() {
......
......@@ -11,7 +11,7 @@ arch="all"
license="PHP"
depends=""
makedepends="php7-dev autoconf"
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
......
......@@ -11,7 +11,7 @@ license="PHP"
options="!check" # Tests fail - does not load msgpack.so
depends="php7-session"
makedepends="php7-dev autoconf"
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
......
......@@ -10,7 +10,7 @@ arch="all"
license="MIT"
depends=""
makedepends="php7-dev autoconf file librdkafka-dev pcre-dev"
# http://pecl.php.net/get/$_pkgreal-$pkgver.tgz does not include the tests
# https://pecl.php.net/get/$_pkgreal-$pkgver.tgz does not include the tests
source="$_pkgreal-$pkgver.tgz::https://github.com/arnaud-lb/php-rdkafka/archive/$pkgver.tar.gz"
builddir="$srcdir/php-$_pkgreal-$pkgver"
......
......@@ -12,7 +12,7 @@ license="PHP"
options="!check" # Require Solr installed
depends="php7-json"
makedepends="php7-dev curl-dev libxml2-dev autoconf pcre-dev"
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz
source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz
fix-zend_acc_public.patch
"
builddir="$srcdir"/$_pkgreal-$_pkgver
......
......@@ -10,7 +10,7 @@ arch="all !s390x" # too many tests fails on s390x
license="PHP-3.01"
depends=""
makedepends="php7-dev autoconf"
source="http://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir"/$_pkgreal-$pkgver
build() {
......
......@@ -12,7 +12,7 @@ license="PHP"
depends=""
pecldepends="php7-dev autoconf util-linux-dev"
makedepends="$pecldepends"
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
source="https://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
builddir="$srcdir/$_pkgreal-$_pkgver"
build() {
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="lzlib"
install=""
subpackages="${pkgname}-doc"
source="http://download.savannah.gnu.org/releases/lzip/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://download.savannah.gnu.org/releases/lzip/$pkgname/$pkgname-$pkgver.tar.gz"