Commit 1e05ed24 authored by Leo's avatar Leo

testing/compton-conf: upgrade to 0.14.1

parent e5e53191
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer:
pkgname=compton-conf
pkgver=0.3.0
pkgrel=1
pkgver=0.14.1
pkgrel=0
pkgdesc="GUI configuration tool for compton X composite manager"
url="https://github.com/lxde/compton-conf"
options="!check" # No testsuite
arch="all"
license="LGPL-2.1"
depends=""
makedepends="cmake libconfig-dev qt5-qtbase-dev qt5-qttools-dev lxqt-build-tools"
install=""
options="!check"
subpackages=""
license="LGPL-2.1-or-later"
depends_dev="libconfig-dev qt5-qtbase-dev qt5-qttools-dev lxqt-build-tools"
makedepends="cmake $depends_dev"
source="compton-conf-$pkgver.tar.gz::https://github.com/lxde/compton-conf/archive/$pkgver.tar.gz"
builddir="$srcdir/compton-conf-$pkgver"
build() {
cd "$builddir"
mkdir build && cd build
if [ "$CBUILD" != "$CHOST" ]; then
CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux \
-DCMAKE_HOST_SYSTEM_NAME=Linux"
fi
cmake \
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
......@@ -34,8 +32,7 @@ build() {
}
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install
make -C build DESTDIR="$pkgdir" install
}
sha512sums="30ecc5f25a3d0aec5ac266a55c1798b875e0dafb4fe73fef6f1e50814be104822139ef0b5bf509824132ecd2dfef4845522b1351da5a40c2977121e5c1d2bcf9 compton-conf-0.3.0.tar.gz"
sha512sums="e40810c44076e9f06970c4645e2f72fadbf7912485f1815d02593ae7a5db4987054f263a73252ba1c99de7b9812decd92021bc5758f211325e494912535c51f7 compton-conf-0.14.1.tar.gz"
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment