Commit 0ed5524b authored by J0WI's avatar J0WI Committed by Natanael Copa

community: (Bulk change) Update source urls to https using HTTPS Everywhere

parent d2bfb22c
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev"
install=""
subpackages=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz"
_builddir="$srcdir/$pkgname-$pkgver"
prepare() {
......
......@@ -12,7 +12,7 @@ depends_dev="libgcrypt-dev libedit-dev ncurses-dev"
makedepends="$depends_dev autoconf automake libtool linux-headers"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/afpfs-ng/afpfs-ng-$pkgver.tar.bz2
source="https://downloads.sourceforge.net/sourceforge/afpfs-ng/afpfs-ng-$pkgver.tar.bz2
00-afpfs-ng-0.8.1-fix_afpfs-ng_includes.patch
01-afpfs-ng-0.8.1-gcrypt.patch
02-afpfs-ng-0.8.1-pointer.patch
......
......@@ -13,7 +13,7 @@ makedepends="autoconf automake libnl3-dev libpcap-dev libressl-dev libtool
linux-headers pcre-dev python3-dev sqlite-dev zlib-dev"
checkdepends="coreutils"
subpackages="$pkgname-doc"
source="http://download.aircrack-ng.org/$pkgname-$_pkgver.tar.gz
source="https://download.aircrack-ng.org/$pkgname-$_pkgver.tar.gz
make-check-fix.patch"
builddir="$srcdir"/$pkgname-$_pkgver
......
......@@ -10,7 +10,7 @@ arch="noarch"
options="!check" # Needs itself for testing.
license="Apache-2.0"
depends="openjdk8-jre-base"
source="http://archive.apache.org/dist/ant/binaries/$pkgname-$pkgver-bin.tar.bz2"
source="https://archive.apache.org/dist/ant/binaries/$pkgname-$pkgver-bin.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
_anthome="/usr/share/java/$pkgname"
......
......@@ -11,7 +11,7 @@ depends_dev="boost-dev libressl-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/sourceforge/asio/$pkgname-$pkgver.tar.bz2"
source="https://downloads.sourceforge.net/sourceforge/asio/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -6,7 +6,7 @@ pkgdesc="An automatic code formatter"
url="http://sourceforge.net/projects/astyle"
arch="all"
license="LGPL"
source="http://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz
source="https://downloads.sourceforge.net/sourceforge/astyle/${pkgname}_${pkgver}_linux.tar.gz
fix-ppc64le-build.patch"
builddir="$srcdir/$pkgname"
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="$depends_dev python2-dev"
install="$pkgname.post-install $pkgname.pre-install"
subpackages=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
$pkgname.initd
$pkgname.confd"
pkgusers="iris"
......
......@@ -15,7 +15,7 @@ makedepends="intltool glib-dev gtk+3.0-dev mate-desktop-dev
poppler-dev tiff-dev itstool libxml2-utils libxml2-dev python2-dev
webkit2gtk-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -10,7 +10,7 @@ makedepends="autoconf automake bash"
arch="all"
license="BSD"
subpackages="$pkgname-doc"
source="http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2"
source="https://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL"
makedepends="linux-headers bash flex byacc libftdi1-dev libusb-compat-dev libelf-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="http://download.savannah.gnu.org/releases/avrdude/${pkgname}-${pkgver}.tar.gz"
source="https://download.savannah.gnu.org/releases/avrdude/${pkgname}-${pkgver}.tar.gz"
builddir="$srcdir/${pkgname}-${pkgver}"
......
......@@ -9,7 +9,7 @@ arch="all"
license="GPL-3.0-or-later"
makedepends="libressl-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz"
source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tgz"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -9,7 +9,7 @@ makedepends="gettext libtool autoconf automake"
arch="all"
license="GPL-2.0 GPL-3.0-or-later LGPL-2.0 BSD"
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2
source="https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2
binutils-ld-fix-static-linking.patch"
builddir="$srcdir/binutils-$pkgver"
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="sqlite-dev"
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
source="https://downloads.sourceforge.net/project/bogofilter/bogofilter-stable/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.bz2"
builddir=${srcdir}/${pkgname}-${pkgver}
......
......@@ -10,7 +10,7 @@ arch="noarch"
license="GPL"
depends="gtk-engines-clearlooks faenza-icon-theme"
subpackages="$pkgname-xfwm4 $pkgname-metacity"
source="http://distfiles.alpinelinux.org/distfiles/121685-BSM%2520Simple%2520$_ver.tar.gz
source="https://distfiles.alpinelinux.org/distfiles/121685-BSM%2520Simple%2520$_ver.tar.gz
bsm-simple-panel.patch
bsm-simple-xfwm.patch"
......
......@@ -11,7 +11,7 @@ depends=""
makedepends="ncurses-dev"
install=""
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.src.tar.gz
source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.src.tar.gz
fix-implicit.patch"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -9,7 +9,7 @@ license="GPL-2.0-or-later"
depends="python2"
makedepends="python2-dev"
subpackages="$pkgname-doc"
source="http://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
source="https://launchpad.net/${pkgname}/${pkgver%.*}/${pkgver}/+download/${pkgname}-${pkgver}.tar.gz
CVE-2017-14176.patch
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -97,7 +97,7 @@ source="
https://hackage.haskell.org/package/hashable-$_hashablever/hashable-$_hashablever.tar.gz
hashable.cabal-$pkgver-$pkgrel::https://hackage.haskell.org/package/hashable-$_hashablever/revision/$_defaultrev.cabal
https://hackage.haskell.org/package/hackage-security-$_hackagesecurityver/hackage-security-$_hackagesecurityver.tar.gz
hackage-security.cabal-$pkgver-$pkgrel::http://hackage.haskell.org/package/hackage-security-$_hackagesecurityver/revision/$_defaultrev.cabal
hackage-security.cabal-$pkgver-$pkgrel::https://hackage.haskell.org/package/hackage-security-$_hackagesecurityver/revision/$_defaultrev.cabal
"
builddir="$srcdir/$pkgname-install-$pkgver"
......
......@@ -11,7 +11,7 @@ depends="attr"
makedepends="rpm file"
options="!check"
subpackages="$pkgname-doc"
source="http://people.redhat.com/~dhowells/cachefs/$pkgname-$pkgver.tar
source="https://people.redhat.com/~dhowells/cachefs/$pkgname-$pkgver.tar
$pkgname.initd"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -17,7 +17,7 @@ subpackages="$pkgname-doc $pkgname-lang $pkgname-setup \
$pkgname-php5:_php $pkgname-php7:_php
"
install="$pkgname.pre-install $pkgname-setup.post-install"
source="http://www.cacti.net/downloads/$pkgname-$pkgver.tar.gz
source="https://www.cacti.net/downloads/$pkgname-$pkgver.tar.gz
$pkgname.crontab
$pkgname.nginx.conf
$pkgname.php-fpm.conf
......
......@@ -11,7 +11,7 @@ depends="caja"
makedepends="glib-dev gtk+3.0-dev caja-dev dconf-dev
mate-desktop-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -13,7 +13,7 @@ makedepends="$depends_dev intltool libtool dconf-dev gtk+3.0-dev libunique3-dev
libsm-dev libnotify-dev mate-desktop-dev libxml2-dev gobject-introspection-dev
gtk-doc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -81,7 +81,7 @@ depends="eudev-libs ttf-opensans"
options=suid
subpackages="$pkgname-chromedriver"
source="https://commondatastorage.googleapis.com/chromium-browser-official/$pkgname-$pkgver.tar.xz
pstables-2.8.h::http://git.savannah.gnu.org/cgit/freetype/freetype2.git/plain/src/psnames/pstables.h?h=VER-2-8
pstables-2.8.h::https://git.savannah.gnu.org/cgit/freetype/freetype2.git/plain/src/psnames/pstables.h?h=VER-2-8
chromium-launcher.sh
chromium.conf
chromium.desktop
......
......@@ -12,7 +12,7 @@ depends_dev="dconf-dev dbus-dev gobject-introspection-dev sqlite-dev
polkit-dev eudev-dev libgudev-dev"
makedepends="$depends_dev intltool bash-completion libgusb-dev lcms2-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="http://www.freedesktop.org/software/colord/releases/colord-$pkgver.tar.xz"
source="https://www.freedesktop.org/software/colord/releases/colord-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -7,7 +7,7 @@ url="https://www.gnu.org/s/ddrescue/ddrescue.html"
arch="all !aarch64"
license="GPL-3.0-or-later"
subpackages="$pkgname-doc"
source="http://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.lz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
......
......@@ -15,7 +15,7 @@ depends_dev="gtk+-dev libmad-dev alsa-lib-dev ffmpeg-dev libsamplerate-dev
makedepends="$depends_dev intltool gettext"
install=""
subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname-$_ver.tar.bz2
source="https://downloads.sourceforge.net/project/$pkgname/$pkgname-$_ver.tar.bz2
arm-buildfix.patch
ppc64le.patch"
......
......@@ -12,7 +12,7 @@ options="!check"
makedepends="linux-headers libx11-dev libxt-dev"
install=""
subpackages="$pkgname-dbg"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
fix-off-by-one.patch
respect-env.patch"
......
......@@ -10,7 +10,7 @@ license="GPL"
makedepends="libpng-dev freetype-dev libdvdread-dev
fribidi-dev libxml2-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
source="https://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz"
builddir="$srcdir/$pkgname"
check() {
......
......@@ -13,7 +13,7 @@ makedepends="$depends_dev swig intltool gettext python2-dev perl-dev"
install=""
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang py-ecryptfs-utils:py"
source="http://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz
source="https://launchpad.net/ecryptfs/trunk/${pkgver}/+download/${pkgname}_${pkgver}.orig.tar.gz
fix-build.patch
fix-stdout-flush.patch
"
......
......@@ -10,7 +10,7 @@ license="GPL-2.0"
depends="libxml2-utils"
makedepends="glib-dev gtk+3.0-dev caja-dev itstool libsm-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -12,7 +12,7 @@ makedepends="glib-dev gtk+3.0-dev itstool mate-desktop-dev
libexif-dev lcms2-dev dconf-dev dbus-dev librsvg-dev
libxslt-dev libpeas-dev dbus-glib-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
source="https://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -11,7 +11,7 @@ depends="hicolor-icon-theme"
makedepends="gtk+3.0-dev libxfce4util-dev libxfce4ui-dev perl perl-uri
libnotify-dev gtk-doc"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="http://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
source="https://archive.xfce.org/src/xfce/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2
mailreader-claws-mail.patch
"
......
......@@ -16,7 +16,7 @@ makedepends="gnutls-dev lame-dev libvorbis-dev xvidcore-dev zlib-dev libvdpau-de
libvpx-dev sdl2-dev libxfixes-dev libva-dev alsa-lib-dev rtmpdump-dev
v4l-utils-dev yasm opus-dev x265-dev libass-dev"
checkdepends="rsync"
source="http://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
0001-libavutil-clean-up-unused-FF_SYMVER-macro.patch
"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -14,7 +14,7 @@ makedepends="$depends_dev
autoconf automake libtool"
install=
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname-${_pkgver}.tar.bz2
source="https://downloads.sourceforge.net/$pkgname/$pkgname-${_pkgver}.tar.bz2
ftgl-2.1.3-rc5-ldflags.patch
ftgl-2.1.3-rc5-ttf_font.patch
"
......
......@@ -9,7 +9,7 @@ license="GPL-2.0"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
makedepends="glib-dev gtk+2.0-dev libxfce4ui-dev intltool libxfce4util-dev
gtk-doc gobject-introspection-dev"
source="http://archive.xfce.org/src/libs/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
source="https://archive.xfce.org/src/libs/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
replaces="xfdesktop"
build() {
......
......@@ -13,29 +13,29 @@ depends_dev="gtk+2.0-dev"
install=
replaces="geany-dev"
source="http://download.$pkgname.org/$pkgname-$pkgver.tar.gz
http://download.geany.org/contrib/tags/dbus-glib-0.76.c.tags
http://download.geany.org/contrib/tags/drupal.php.tags
http://download.geany.org/contrib/tags/ethos-1.0.c.tags
http://download.geany.org/contrib/tags/geany-api-0.19.c.tags
http://download.geany.org/contrib/tags/gladeui-1.0.c.tags
http://download.geany.org/contrib/tags/gnt.c.tags
http://download.geany.org/contrib/tags/gtk220.c.tags
http://download.geany.org/contrib/tags/gtkscintilla-2.0.c.tags
http://download.geany.org/contrib/tags/gtksourceview-3.0.c.tags
http://download.geany.org/contrib/tags/libdevhelp-2.0.c.tags
http://download.geany.org/contrib/tags/libgdl-3.0.c.tags
http://download.geany.org/contrib/tags/libxml-2.0.c.tags
http://download.geany.org/contrib/tags/openjdk8-8u66-b01.java.tags
http://download.geany.org/contrib/tags/sqlite3.c.tags
http://download.geany.org/contrib/tags/standard.css.tags
http://download.geany.org/contrib/tags/std.glsl.tags
http://download.geany.org/contrib/tags/std.latex.tags
http://download.geany.org/contrib/tags/std.vala.tags
http://download.geany.org/contrib/tags/v4l2.c.tags
http://download.geany.org/contrib/tags/webkit-1.0.c.tags
http://download.geany.org/contrib/tags/wordpress.php.tags
http://download.geany.org/contrib/tags/xfce46.c.tags
http://download.geany.org/contrib/tags/xfce48.c.tags
https://download.geany.org/contrib/tags/dbus-glib-0.76.c.tags
https://download.geany.org/contrib/tags/drupal.php.tags
https://download.geany.org/contrib/tags/ethos-1.0.c.tags
https://download.geany.org/contrib/tags/geany-api-0.19.c.tags
https://download.geany.org/contrib/tags/gladeui-1.0.c.tags
https://download.geany.org/contrib/tags/gnt.c.tags
https://download.geany.org/contrib/tags/gtk220.c.tags
https://download.geany.org/contrib/tags/gtkscintilla-2.0.c.tags
https://download.geany.org/contrib/tags/gtksourceview-3.0.c.tags
https://download.geany.org/contrib/tags/libdevhelp-2.0.c.tags
https://download.geany.org/contrib/tags/libgdl-3.0.c.tags
https://download.geany.org/contrib/tags/libxml-2.0.c.tags
https://download.geany.org/contrib/tags/openjdk8-8u66-b01.java.tags
https://download.geany.org/contrib/tags/sqlite3.c.tags
https://download.geany.org/contrib/tags/standard.css.tags
https://download.geany.org/contrib/tags/std.glsl.tags
https://download.geany.org/contrib/tags/std.latex.tags
https://download.geany.org/contrib/tags/std.vala.tags
https://download.geany.org/contrib/tags/v4l2.c.tags
https://download.geany.org/contrib/tags/webkit-1.0.c.tags
https://download.geany.org/contrib/tags/wordpress.php.tags
https://download.geany.org/contrib/tags/xfce46.c.tags
https://download.geany.org/contrib/tags/xfce48.c.tags
http://advamacs.com/pub/tcl.tcl.tags
set_default_terminal.patch
"
......
......@@ -9,7 +9,7 @@ license="GPL-3.0 LGPL-3.0"
makedepends="babl-dev libpng-dev libjpeg-turbo-dev gtk+-dev librsvg-dev
lua5.1-dev jasper-dev exiv2-dev json-glib-dev"
subpackages="$pkgname-dev $pkgname-lang"
source="http://ftp.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
source="https://ftp.gimp.org/pub/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
builddir="$srcdir"/$pkgname-$pkgver
build() {
......
......@@ -12,7 +12,7 @@ makedepends="$depends_dev glib-dev gobject-introspection-dev intltool
json-glib-dev libsoup-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://download.gnome.org/sources/geocode-glib/${pkgver%.*}/geocode-glib-$pkgver.tar.xz"
source="https://download.gnome.org/sources/geocode-glib/${pkgver%.*}/geocode-glib-$pkgver.tar.xz"
builddir="$srcdir"/geocode-glib-$pkgver
prepare() {
......
......@@ -16,7 +16,7 @@ makedepends="glib-dev gnutls-dev libproxy-dev intltool libgcrypt-dev bash
p11-kit-dev meson gsettings-desktop-schemas-dev"
install=
subpackages="$pkgname-lang"
source="http://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
source="https://download.gnome.org/sources/glib-networking/$_ver/glib-networking-$pkgver.tar.xz"
options="!check"
build() {
......
......@@ -11,7 +11,7 @@ depends_dev=""
makedepends="$depends_dev icon-naming-utils"
install=""
subpackages=""
source="http://download.gnome.org/sources/gnome-icon-theme-symbolic/${pkgver%.*}/gnome-icon-theme-symbolic-$pkgver.tar.xz"
source="https://download.gnome.org/sources/gnome-icon-theme-symbolic/${pkgver%.*}/gnome-icon-theme-symbolic-$pkgver.tar.xz"
_builddir="$srcdir"/gnome-icon-theme-symbolic-$pkgver
prepare() {
......
......@@ -10,7 +10,7 @@ license="MIT"
makedepends="cairo-dev pango-dev gd-dev lua5.3-dev readline-dev
libpng-dev libjpeg-turbo-dev"
subpackages="$pkgname-doc"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/project/$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -12,7 +12,7 @@ depends_dev=""
makedepends="bash go-bootstrap"
install=""
subpackages="$pkgname-doc"
source="http://golang.org/dl/go${pkgver/_/}.src.tar.gz
source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
default-buildmode-pie.patch
set-external-linker.patch
"
......
......@@ -9,7 +9,7 @@ arch="all"
license="MIT"
makedepends="jasper-dev libpng-dev tiff-dev libxml2-dev libwmf-dev freetype-dev libtool libltdl"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/$pkgname/$pkgname/$pkgver/GraphicsMagick-$pkgver.tar.xz"
source="https://downloads.sourceforge.net/$pkgname/$pkgname/$pkgver/GraphicsMagick-$pkgver.tar.xz"
options="libtool !check"
builddir="$srcdir"/GraphicsMagick-$pkgver
......
......@@ -9,7 +9,7 @@ license="GPL-2.0-or-later gSOAP-1.3b"
url="http://gsoap2.sourceforge.net"
makedepends="autoconf automake bison flex libressl-dev libtool zlib-dev"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip
source="https://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip
musl-fixes.patch
"
builddir="$srcdir/$pkgname-${pkgver%.*}"
......
......@@ -8,7 +8,7 @@ arch="all !armhf !armv7"
license="GPL"
makedepends="gstreamer0.10-dev gst-plugins-base0.10-dev orc-dev coreutils
orc-dev"
source="http://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-$pkgver.tar.bz2
source="https://gstreamer.freedesktop.org/src/gst-ffmpeg/gst-ffmpeg-$pkgver.tar.bz2
libavutil-fortify.patch
"
......
......@@ -13,7 +13,7 @@ makedepends="gtk+3.0-dev eudev-dev sdl-dev portaudio-dev ffmpeg-dev gsl-dev
v4l-utils-dev libusb-dev linux-headers"
install=
subpackages="$pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/project/guvcview/source/guvcview-src-$pkgver.tar.gz
source="https://downloads.sourceforge.net/project/guvcview/source/guvcview-src-$pkgver.tar.gz
0001-fix-building-with-musl-libc.patch
"
......
......@@ -10,7 +10,7 @@ license="GPL-2.0-or-later LGPL-2.0-or-later MPL-1.1"
subpackages="$pkgname-dev $pkgname-en"
depends_dev="perl"
makedepends="$depends_dev"
source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -11,7 +11,7 @@ makedepends="$depends_dev bison flex libxcb-dev xcb-util-cursor-dev
xcb-util-keysyms-dev xcb-util-wm-dev libev-dev pango-dev cairo-dev
yajl-dev startup-notification-dev pcre-dev libxkbcommon-dev xcb-util-xrm-dev"
subpackages="$pkgname-doc"
source="http://i3wm.org/downloads/i3-$pkgver.tar.bz2
source="https://i3wm.org/downloads/i3-$pkgver.tar.bz2
i3wm-musl-glob-tilde.patch
"
builddir="$srcdir/i3-$pkgver"
......
......@@ -17,7 +17,7 @@ makedepends="fontconfig-dev freetype-dev ghostscript-dev lcms2-dev
libjpeg-turbo-dev libpng-dev librsvg-dev libtool libxml2-dev tiff-dev
zlib-dev"
subpackages="$pkgname-doc $pkgname-dev $pkgname-c++:_cxx $pkgname-libs"
source="http://www.imagemagick.org/download/releases/$_pkgname-$_pkgver.tar.xz"
source="https://www.imagemagick.org/download/releases/$_pkgname-$_pkgver.tar.xz"
builddir="$srcdir/$_pkgname-$_pkgver"
prepare() {
......
......@@ -13,7 +13,7 @@ makedepends="$depends_dev"
install="$pkgname.post-install $pkgname.post-deinstall"
subpackages="$pkgname-doc"
options="!check"
source="http://ftp.gnu.org/gnu/inetutils/${_pkgname}-${pkgver}.tar.gz
source="https://ftp.gnu.org/gnu/inetutils/${_pkgname}-${pkgver}.tar.gz
$pkgname.initd
$pkgname.confd
syslog.conf
......
......@@ -10,7 +10,7 @@ license="zlib"
depends=""
makedepends="mesa-dev libjpeg-turbo-dev bzip2 libpng-dev zlib-dev bzip2-dev"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip
source="https://downloads.sourceforge.net/irrlicht/irrlicht-$pkgver.zip
irrlicht-1.8.3-mesa-10.x.patch
irrlicht-1.8.3-sysctl.patch
irrlicht-1.8-optflags.patch
......
......@@ -10,7 +10,7 @@ license="GPL-2.0"
depends=""
makedepends="$depends_dev libressl-dev cyrus-sasl-dev zlib-dev db-dev perl-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::http://downloads.sourceforge.net/sourceforge/isync/$pkgname-$pkgver.tar.gz
source="$pkgname-$pkgver.tar.gz::https://downloads.sourceforge.net/sourceforge/isync/$pkgname-$pkgver.tar.gz
libressl-compat.patch
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -8,7 +8,7 @@ url="http://junit.org/"
arch="noarch"
license="EPL-1.0"
depends=""
source="http://search.maven.org/remotecontent?filepath=$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.jar"
source="https://search.maven.org/remotecontent?filepath=$pkgname/$pkgname/$pkgver/$pkgname-$pkgver.jar"
_builddir="$srcdir"
......
......@@ -13,7 +13,7 @@ depends_dev=""
makedepends="autoconf automake flex bison"
install=""
subpackages="$pkgname-doc"
source="http://dev.gentoo.org/~polynomial-c/kBuild-${_ver}-src.tar.xz
source="https://dev.gentoo.org/~polynomial-c/kBuild-${_ver}-src.tar.xz
lchmod.patch
strlcpy.patch
underlinking.patch
......
......@@ -9,7 +9,7 @@ url="http://www.keepassx.org"
arch="all"
license="GPL-2.0"
makedepends="cmake qt-dev libxtst-dev libgcrypt-dev"
source="http://www.keepassx.org/releases/${pkgver}/${pkgname}-${pkgver}.tar.gz
source="https://www.keepassx.org/releases/${pkgver}/${pkgname}-${pkgver}.tar.gz
musl-fixes.patch
"
builddir="$srcdir"/$pkgname-$pkgver
......
......@@ -11,7 +11,7 @@ depends=""
makedepends=""
install=""
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -11,7 +11,7 @@ license="LGPL-2.0 GPL-2.0"
makedepends="intltool gdk-pixbuf-dev gobject-introspection-dev libxml2-dev
pango-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-render"
source="http://download.gnome.org/sources/lasem/${pkgver%.*}/lasem-$pkgver.tar.xz
source="https://download.gnome.org/sources/lasem/${pkgver%.*}/lasem-$pkgver.tar.xz
install-mathml-headers.patch"
builddir="$srcdir/$pkgname-$pkgver"
......
......@@ -11,7 +11,7 @@ depends=""
depends_dev="gtk+2.0-dev"
makedepends="$depends_dev"
subpackages="$pkgname-lang"
source="http://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
source="https://download.savannah.gnu.org/releases/${pkgname}/${pkgname}-${pkgver}.tar.gz"
builddir="$srcdir"/${pkgname}-${pkgver}
build() {
......
......@@ -11,7 +11,7 @@ depends="ca-certificates"
depends_dev=""
makedepends="$depends_dev go git libcap"
subpackages=""
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
use-correct-version.patch
b5d5eee2dd269f88f181d7a437be80194bfd0235.patch
"
......
......@@ -9,7 +9,7 @@ arch="all"
license="LGPL-3.0"
makedepends="py-docutils cmake doxygen libpng glib-dev"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
source="https://downloads.sourceforge.net/project/$pkgname/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
......
......@@ -10,7 +10,7 @@ license="MPL-2.0"
depends_dev="librevenge-dev libxml2-dev zlib-dev boost-dev"
makedepends="$depends_dev doxygen gperf perl"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
builddir="$srcdir/$pkgname-$pkgver"
......