Commit cd625313 authored by Leonardo Arena's avatar Leonardo Arena

main/py-django: upgrade to 1.11.9, fix depends

parent c2f71791
......@@ -2,19 +2,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-django
_pkgname=Django
pkgver=1.11.5
pkgver=1.11.9
pkgrel=0
pkgdesc="A high-level Python Web framework"
url="http://djangoproject.com/"
arch="noarch"
license="BSD"
depends=""
depends_dev=""
depends="py-tz"
makedepends="python2-dev python3-dev py-setuptools"
install=""
options="!check" # some depends missing, others in community/testing
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
# secfixes:
......@@ -33,6 +31,12 @@ build() {
python3 setup.py --quiet build
}
check() {
cd "$builddir"/tests
python2 runtests.py
python3 runtests.py
}
package() {
mkdir -p "$pkgdir"/usr/bin
......@@ -44,10 +48,12 @@ package() {
_py2() {
replaces="$pkgname"
depends="${depends//py-/py2-}"
_py python2
}
_py3() {
depends="${depends//py-/py3-}"
_py python3
}
......@@ -67,4 +73,4 @@ _py() {
done
}
sha512sums="bd43524d80721f10e98ca1cb2d487b51258c5e66febcda4ff4487c4c057f2920bb84452ff966b1cfe5dbb7d11138b467f7e1d65017ac9dd92f76497147fce89c Django-1.11.5.tar.gz"
sha512sums="140e59126bb278777adb9a89e00e3d2458c50175f48fd48b92574cdf05ea9378ea06f2e9488890d75622931e35c5dc1b0a0206b311e0a2e7738e409feef14152 Django-1.11.9.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment