Commit 4f82f477 authored by Francesco Colista's avatar Francesco Colista

community/gns-server: added dependencies for aiohttp1

In Alpine repo we have aiohttp 2.x only, but this is incompatible
with GNS3.
Bug sent to upstream https://github.com/GNS3/gns3-server/issues/1054
In the meanwhile, we created a py3-aiohttp1 package to make GNS3 work again
parent 72005878
......@@ -2,13 +2,13 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=gns3-server
pkgver=2.0.2
pkgrel=0
pkgrel=1
pkgdesc="GNS3 network simulator. Server package."
url="https://github.com/GNS3/gns3-server"
arch="all"
license="GPL3"
depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp
py3-aiohttp-cors py3-pytest py3-netifaces py3-ws4py py3-zipstream
depends="busybox dynamips python3 py3-psutil py3-jinja2 py3-aiohttp1
py3-aiohttp1-cors py3-pytest py3-netifaces py3-ws4py py3-zipstream
py3-raven py3-jsonschema py3-yarl"
makedepends="busybox-static py-setuptools python3-dev linux-headers py3-pytest"
subpackages="$pkgname-doc"
......@@ -52,4 +52,4 @@ EOF
}
sha512sums="b239840f6a1e01fb12513f269700d0d9642765768b7c90e49f086f85fb57d52e71792f559e0cde9d195cdef40685893fde120cf82747f283c27541b5540c6b80 gns3-server-2.0.2.tar.gz
ff2f247936eae3d4edc15c707b0d35b087b918fe4eb551546f1e30930e248e68493a1f122dbc080aea837e343ef651d67ed9febc645595b4b6d28e25540b4de0 dropped-requirements.patch"
e698dd1165b4493c8b467618ccffd31395af5832975a520a239fb03ec62678c3528f386eadd309686bd2cd73b89246c225510cc08bec5ff7389f2de84a380ca3 dropped-requirements.patch"
diff --git a/requirements.txt b/requirements.txt
index 775d220..1c81f17 100644
index 648cf5f..1c81f17 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -1,7 +1,7 @@
@@ -1,9 +1,8 @@
jsonschema>=2.4.0
-aiohttp>=1.3.5,<=1.4.0 # pyup: ignore
-aiohttp-cors==0.5.1 # pyup: ignore
......@@ -13,3 +13,5 @@ index 775d220..1c81f17 100644
Jinja2>=2.7.3
raven>=5.23.0
psutil>=3.0.0
zipstream>=1.1.4
-typing>=3.5.3.0 # Otherwise yarl fail with python 3.4
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment