APKBUILD 1.14 KB
Newer Older
1 2 3
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=pulseaudio-qt
4
pkgver=1.2
5
pkgrel=0
6
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
7 8 9 10 11 12
url="https://cgit.kde.org/pulseaudio-qt.git/"
pkgdesc="Pulseaudio bindings for Qt"
license="LGPL-2.1-only OR LGPL-3.0-only"
depends_dev="qt5-qtbase-dev pulseaudio-dev glib-dev"
makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
checkdepends="qt5-qtdeclarative-dev"
13
source="https://download.kde.org/stable/pulseaudio-qt/pulseaudio-qt-$pkgver.tar.xz"
14 15
subpackages="$pkgname-dev $pkgname-doc"

16 17 18 19 20 21
prepare() {
	default_prepare

	mkdir "$builddir"/build
}

22
build() {
23 24
	cd "$builddir"/build
	cmake "$builddir" \
25 26 27 28 29 30 31 32
		-DCMAKE_BUILD_TYPE=RelWithDebInfo \
		-DCMAKE_INSTALL_PREFIX=/usr \
		-DCMAKE_INSTALL_LIBDIR=lib \
		-DBUILD_QCH=ON
	make
}

check() {
33
	cd "$builddir"/build
34 35 36 37
	CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}

package() {
38
	cd "$builddir"/build
39 40 41
	DESTDIR="$pkgdir" make install
}

42
sha512sums="20bddc4db80310bf46b37a1a386f714bfa3dc2a58871bdd0c0085675c43b42e24792d05cbe5543135a341588e17738525f03ccb08adbc73e1c65967039b35dc7  pulseaudio-qt-1.2.tar.xz"