Commit 3389e6f6 authored by Leo's avatar Leo
Browse files

community/py3-yoyo-migrations: add missing dependency on py3-setuptools

it uses 'pkg_resources' in its code

also remove python3-dev which is not required unless one is compiling C
extensions and C extensions require the package to not be 'noarch'

fixes #12599
parent 37a92cdb
......@@ -7,8 +7,7 @@ pkgdesc="Database migrations with SQL"
url="https://ollycope.com/software/yoyo/latest/"
arch="noarch"
license="Apache-2.0"
depends="py3-text-unidecode py3-iniherit"
makedepends="python3-dev py3-setuptools"
depends="py3-text-unidecode py3-iniherit py3-setuptools"
options="!check" # no tests in pypi tarballs
source="https://pypi.io/packages/source/y/yoyo-migrations/yoyo-migrations-$pkgver.tar.gz"
builddir="$srcdir/yoyo-migrations-$pkgver"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment