diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 0ac37a357a2d71944d9feb51ab0b38e6b521e2d6..f4829d39686d3c52ceea7317f2a016ea5b362479 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -1,7 +1,7 @@
 # Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
 # Contributor: Jakub Jirutka <jakub@jirutka.cz>
 pkgname=nextcloud
-pkgver=13.0.6
+pkgver=14.0.0
 pkgrel=0
 pkgdesc="A safe home for all your data"
 url="http://nextcloud.com"
@@ -21,7 +21,7 @@ install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade
 subpackages="$pkgname-doc $pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkgname-sqlite
 	$pkgname-default-apps:_default_apps"
 source="https://download.nextcloud.com/server/releases/$pkgname-$pkgver.zip
-	nextcloud10-dont-chmod.patch
+	nextcloud14-dont-chmod.patch
 	dont-update-htaccess.patch
 	disable-integrity-check-as-default.patch
 	app-encryption-info-add-mcrypt.patch
@@ -223,11 +223,11 @@ _package_app() {
 	mv "$pkgdir"/$_appsdir/$appname "$subpkgdir"/$_appsdir/
 }
 
-sha512sums="76fa7fab040d121319375a90d13d75119b098afcd954acfece021c94e7bd6f0801f2f2359f27987c3ff3cfb95bcbd338a3aa26cb5cdc7f453a88414745fcac5f  nextcloud-13.0.6.zip
-9c20237c4952ff543171768160c17c3608cc43ad9592fecccaeb337787d566f039f27f30f118359dfff7db58cd12d811c05be15e5994efee57a9ed75787d71f5  nextcloud10-dont-chmod.patch
+sha512sums="9ff01cfa2a27a0447e380f575542a85a567b42821f7b764abeb873e56a187050c52b5a5780a06ea8ba880767ee417cd8ecfbb074153489f0f335eae6d5c979ba  nextcloud-14.0.0.zip
+63690b8d8ffe6d4896c5b666aa9d493b501aa3e171c6557e7a003599049f0d36f266a2a257a9535dea055bca1e84208b219c6cd5e4ecd70dd064e1dd1007203a  nextcloud14-dont-chmod.patch
 aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845fdbb389c3c965a75b8b14b9247513c05cf4130fe1cfc61731  dont-update-htaccess.patch
-04783385ca35be9e8b895e91294b082cd2a1f50c4e17dc195901885ecd421db9a6fe45360d7eac623873ae4efad80b92f31ebde59f4ed76d832c8cac450dac85  disable-integrity-check-as-default.patch
-d6f951cbcb7ca48beb88d77e02a8669677e87bc32189b1eb7e63edc29c293bd6e1ee471c37b622e6b38fd2baf6cf198c872f92b256ffab17c92c31a3a05b5aa0  app-encryption-info-add-mcrypt.patch
+ebeabf850761348346c1e10a60a6f67771a30efc308e4f776f1455f8b48ee357c51c4821e1db92453f1548345a5c6005ea0eb642fb6a4fd0ee910c68a65e3290  disable-integrity-check-as-default.patch
+7dd7113ab34aedea23b377e465b39f20123495c83eae4e4b0120bc843b124a25930c2ff27617c11615e6ad987257005a1eaf59c7f57b88f0878c8d00cbef5f55  app-encryption-info-add-mcrypt.patch
 7d60ba2f1c012b0a1cded30f757b7ec0efe7fc4bfa7b5c6879f35eb80711ac1d5e6c894356346222a0de68b0808c99bac358aaae1c69124a855da2a98cdff6ec  iconv-ascii-translit-not-supported.patch
 478f5cd7c5d30380ea619d3e8ec623217a06a09b27534266f00297545c7d276b068c5d984673eebc5676e8bac7f45112549498944ce3fa678ac8a69541d7c430  use-external-docs-if-local-not-avail.patch
 5f73cd9399fa484ef15bd47e803c93381deffbc7699eceadbb5c27e43b20156806d74e5021a64d28f0165ef87b519e962780651711a37bceb9f0b04455dfdce1  nextcloud-config.php
diff --git a/community/nextcloud/app-encryption-info-add-mcrypt.patch b/community/nextcloud/app-encryption-info-add-mcrypt.patch
index 35b7557ab51309b4074fcc535960cd6a218f7857..88b270737c870c267f7519b93f9730dd8d53254a 100644
--- a/community/nextcloud/app-encryption-info-add-mcrypt.patch
+++ b/community/nextcloud/app-encryption-info-add-mcrypt.patch
@@ -1,15 +1,10 @@
-mcrypt is not required, but it's recommended to increase file encryption
-performance. We're adding it to info.xml just to simplify abuild (all app
-dependencies can be read in info.xml).
-
 --- a/apps/encryption/appinfo/info.xml
 +++ b/apps/encryption/appinfo/info.xml
-@@ -25,6 +25,7 @@
- 	</types>
+@@ -31,6 +31,7 @@
+ 
  	<dependencies>
  		<lib>openssl</lib>
 +		<lib>mcrypt</lib>
- 		<nextcloud min-version="13" max-version="13" />
+ 		<nextcloud min-version="14" max-version="14" />
  	</dependencies>
- 	<settings>
-
+ 
diff --git a/community/nextcloud/disable-integrity-check-as-default.patch b/community/nextcloud/disable-integrity-check-as-default.patch
index 87108c600a81b30276ce958ed136eb6478e9f7df..cf6391a3332320d70222fad2bf26d9a20465deb1 100644
--- a/community/nextcloud/disable-integrity-check-as-default.patch
+++ b/community/nextcloud/disable-integrity-check-as-default.patch
@@ -1,15 +1,11 @@
-We patch some files and Nextcloud's integrity check doesn't like it...
-APK ensures integrity of all installed files, so this Nextcloud's integrity
-check doesn't add any value.
-
 --- a/lib/private/IntegrityCheck/Checker.php
 +++ b/lib/private/IntegrityCheck/Checker.php
-@@ -109,7 +109,7 @@ class Checker {
- 		 * too prominent. So please do not add it to config.sample.php.
+@@ -111,7 +111,7 @@
  		 */
+ 		$isIntegrityCheckDisabled = false;
  		if ($this->config !== null) {
 -			$isIntegrityCheckDisabled = $this->config->getSystemValue('integrity.check.disabled', false);
 +			$isIntegrityCheckDisabled = $this->config->getSystemValue('integrity.check.disabled', true);
- 		} else {
- 			$isIntegrityCheckDisabled = false;
  		}
+ 		if ($isIntegrityCheckDisabled === true) {
+ 			return false;
diff --git a/community/nextcloud/nextcloud-1202-fix-6028.patch b/community/nextcloud/nextcloud-1202-fix-6028.patch
deleted file mode 100644
index bc7f64f79627e55fb1207845bd7604b379e7081f..0000000000000000000000000000000000000000
--- a/community/nextcloud/nextcloud-1202-fix-6028.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- a/lib/private/Template/CSSResourceLocator.php
-+++ b/lib/private/Template/CSSResourceLocator.php
-@@ -117,7 +117,7 @@
- 			parent::append($root, $file, $webRoot, $throw);
- 		} else {
- 			if (!$webRoot) {
--				$tmpRoot = realpath($root);
-+				$tmpRoot = $root;
- 				/*
- 				 * traverse the potential web roots upwards in the path
- 				 *
---- a/lib/private/Template/ResourceLocator.php
-+++ b/lib/private/Template/ResourceLocator.php
-@@ -125,7 +125,7 @@
- 		}
- 
- 		if (!$webRoot) {
--			$tmpRoot = realpath($root);
-+			$tmpRoot = $root;
- 			/*
- 			 * traverse the potential web roots upwards in the path
- 			 *
diff --git a/community/nextcloud/nextcloud10-dont-chmod.patch b/community/nextcloud/nextcloud14-dont-chmod.patch
similarity index 86%
rename from community/nextcloud/nextcloud10-dont-chmod.patch
rename to community/nextcloud/nextcloud14-dont-chmod.patch
index 0a3b11975e9aecb063e27b34d808b760bc0ec506..13b5e3efbf26db61aabb78964fab978ea275cefd 100644
--- a/community/nextcloud/nextcloud10-dont-chmod.patch
+++ b/community/nextcloud/nextcloud14-dont-chmod.patch
@@ -1,6 +1,6 @@
 --- a/lib/private/Config.php
 +++ b/lib/private/Config.php
-@@ -229,9 +229,6 @@
+@@ -240,9 +240,6 @@
  		touch ($this->configFilePath);
  		$filePointer = fopen($this->configFilePath, 'r+');
  
@@ -12,19 +12,19 @@
  			// TODO fix this via DI once it is very clear that this doesn't cause side effects due to initialization order
 --- a/lib/private/Log/File.php
 +++ b/lib/private/Log/File.php
-@@ -130,9 +130,6 @@
+@@ -134,9 +134,6 @@
  		}
  		$entry = json_encode($entry, JSON_PARTIAL_OUTPUT_ON_ERROR);
- 		$handle = @fopen(self::$logFile, 'a');
--		if ((fileperms(self::$logFile) & 0777) != 0640) {
--			@chmod(self::$logFile, 0640);
+ 		$handle = @fopen($this->logFile, 'a');
+-		if ((fileperms($this->logFile) & 0777) != 0640) {
+-			@chmod($this->logFile, 0640);
 -		}
  		if ($handle) {
  			fwrite($handle, $entry."\n");
  			fclose($handle);
 --- a/lib/private/TempManager.php
 +++ b/lib/private/TempManager.php
-@@ -94,7 +94,6 @@
+@@ -95,7 +95,6 @@
  			if($postFix !== '') {
  				$fileNameWithPostfix = $this->buildFileNameWithSuffix($file, $postFix);
  				touch($fileNameWithPostfix);
@@ -34,7 +34,7 @@
  			}
 --- a/lib/private/legacy/util.php
 +++ b/lib/private/legacy/util.php
-@@ -965,7 +965,6 @@
+@@ -1008,7 +1008,6 @@
  			. ' cannot be listed by other users.');
  		$perms = substr(decoct(@fileperms($dataDirectory)), -3);
  		if (substr($perms, -1) !== '0') {