Commit a5f34eda authored by Timo Teräs's avatar Timo Teräs
Browse files

main/apk-tools: upgrade to 2.10.6

parent ffd9622f
From 947baeea1860a4eb44bb8636e1db295a7bc1d259 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Thu, 10 Jan 2019 09:29:35 +0100
Subject: [PATCH] fetch: fix error message for --recursive
Give error message for `apk fetch --recursive missing`
---
src/fetch.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/src/fetch.c b/src/fetch.c
index e745d84..9a7c46a 100644
--- a/src/fetch.c
+++ b/src/fetch.c
@@ -229,8 +229,10 @@ static void mark_name_flags(struct apk_database *db, const char *match, struct a
if (!IS_ERR_OR_NULL(name)) {
name->auto_select_virtual = 1;
apk_deps_add(&ctx->world, &dep);
- } else
+ } else {
ctx->errors++;
+ mark_error(ctx, match, name);
+ }
}
static void mark_names_recursive(struct apk_database *db, struct apk_string_array *args, void *pctx)
--
2.20.1
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apk-tools
pkgver=2.10.3
pkgrel=1
pkgver=2.10.6
pkgrel=0
pkgdesc="Alpine Package Keeper - package manager for alpine"
arch="all"
url="https://gitlab.alpinelinux.org/alpine/apk-tools"
license=GPL2
subpackages="$pkgname-static"
depends=
makedepends_build="openssl"
......@@ -12,15 +15,9 @@ if [ "$CBUILD" = "$CHOST" ]; then
subpackages="$subpackages lua5.2-apk:luaapk"
makedepends="$makedepends lua5.2-dev"
fi
source="https://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
0001-fetch-fix-error-message-for-recursive.patch
"
url="https://git.alpinelinux.org/cgit/apk-tools/"
arch="all"
license=GPL2
source="https://gitlab.alpinelinux.org/alpine/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare || return 1
cd "$builddir"
......@@ -32,6 +29,7 @@ prepare() {
echo "LUAAPK=" >> config.mk
fi
echo "export LUAAPK" >> config.mk
echo "export LUA_VERSION=5.2" >> config.mk
}
build() {
......@@ -59,7 +57,7 @@ package() {
static() {
pkgdesc="Alpine Package Keeper - static binary"
install -Dm755 "$srcdir"/$pkgname-$pkgver/src/apk.static \
install -Dm755 "$builddir"/src/apk.static \
"$subpkgdir"/sbin/apk.static
# lets sign the static binary so it can be vefified from distros
......@@ -83,5 +81,4 @@ luaapk() {
mv "$pkgdir"/usr/lib "$subpkgdir"/usr/lib/
}
sha512sums="1b190cfd04c69369bd4f2b708d4df0f8cf2937e1580c95138fd2c2257e7604d015deaca10a9fe0da6742981caadb6b067c15e417a1951866f781b8a5c71c98ee apk-tools-2.10.3.tar.xz
0fe8d05d6d1c3f6ed5c86d5a5a9aca4fd5246579ed346adb990b8fba6dcac0033056a655181659b4e12a8c934d27df512d29e4e134889a4eafcfbf80e60da2a5 0001-fetch-fix-error-message-for-recursive.patch"
sha512sums="81e51fdaf7976d589c847850dc3494a6bb91847f14a756e1dd9afe7f526b672e6aab743965506ef89e3229084bc92c9041a49796b400f454a2c912efebd44b4f apk-tools-v2.10.6.tar.gz"
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment